Add RTL to the Saved Addresses and Saved Credit Cards dialogs

RESOLVED FIXED in Firefox 59

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: itiel_yn8, Assigned: scottwu)

Tracking

(Depends on 1 bug, Blocks 1 bug, {rtl})

unspecified
mozilla59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox58 wontfix, firefox59 fixed)

Details

Attachments

(7 attachments)

Current implementations of the Saved Addresses and Saved Credit Cards dialogs in the Options tab are missing RTL support.

See attached exmaples for how it currently looks on RTL.
Posted image Saved Addresses add
Posted image Saved Addresses main
Scott, can you look in to this?
Component: Preferences → Form Autofill
Flags: needinfo?(scwwu)
Priority: -- → P1
Product: Firefox → Toolkit
Thanks Jared. I think I know what the cause is.
Assignee: nobody → scwwu
Status: NEW → ASSIGNED
Flags: needinfo?(scwwu)
It appears that the RTL rule is set by each locale in `intl.css`, with style rules like this: https://hg.mozilla.org/l10n-central/fa/file/tip/toolkit/chrome/global/intl.css#l23

However Form Autofill subdialogs load XHTML files rather than XUL, so the direction rule does not apply to them. I think a simple way to get around this is to manually apply the parent element's direction attribute to the subdialog documents. Wonder what your thoughts are with this approach?

Thanks!
Flags: needinfo?(MattN+bmo)
Try using the &locale.dir; entity:
https://dxr.mozilla.org/mozilla-central/search?q=locale.dir
<!ENTITY % globalDTD SYSTEM "chrome://global/locale/global.dtd">
   %globalDTD;
https://dxr.mozilla.org/mozilla-central/source/dom/locales/en-US/chrome/global.dtd#5
Flags: needinfo?(MattN+bmo)
Comment on attachment 8940657 [details]
Bug 1416503 - Add RTL support for Form Autofill preference dialogs.

https://reviewboard.mozilla.org/r/210896/#review217452
Attachment #8940657 - Flags: review?(lchang) → review+
Pushed by lchang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7b110713598d
Add RTL support for Form Autofill preference dialogs. r=lchang
https://hg.mozilla.org/mozilla-central/rev/7b110713598d
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Hi Itiel, we just landed this bug. Can you help to verify if the layout is correct now ? Thank you.
Flags: needinfo?(itiel_yn8)
(In reply to Lauren Fu(Firefox EPM) from comment #14)
> Hi Itiel, we just landed this bug. Can you help to verify if the layout is
> correct now ? Thank you.

There indeed is a change, but some buttons and text (the table's labels) are hidden.
I think that the list of items should also be right aligned, but as I don't have internet access to add items in there, I can't be sure, so I'll check when I get back home.
See attached screenshots.
Flags: needinfo?(itiel_yn8)
(In reply to Itiel from comment #15)
> There indeed is a change, but some buttons and text (the table's labels) are
> hidden.
> I think that the list of items should also be right aligned, but as I don't
> have internet access to add items in there, I can't be sure, so I'll check
> when I get back home.
> See attached screenshots.

So the items list is indeed RTL, but the blue dotted outline (which shouldn't be there at all I guess, if no items are present), is still LTR.

Lauren, should we reopen here?
Flags: needinfo?(yfu)
No, please file new bugs for issues which aren't already filed. We generally only re-open a FIXED bug if the code gets backed out but since it seems like the change made some improvements and didn't cause major regressions, follow-up bugs would be better.
Flags: needinfo?(yfu)
Hi Itiel can you help to file this bug again and I will ni Scott in the new bug. Thank you.
Flags: needinfo?(itiel_yn8)
Thanks Itiel, I'm looking into it. It doesn't seem to affect Mac and Linux, and on Windows it looks fine on en-US too. If HE has problems with it other locales might too.
The blue dotted line issue has been file under Bug 1390674.
Depends on: 1430032
(In reply to Matthew N. [:MattN] (PM if requests are blocking you) from comment #19)
> No, please file new bugs for issues which aren't already filed. We generally
> only re-open a FIXED bug if the code gets backed out but since it seems like
> the change made some improvements and didn't cause major regressions,
> follow-up bugs would be better.

(In reply to Lauren Fu(Firefox EPM) from comment #20)
> Hi Itiel can you help to file this bug again and I will ni Scott in the new
> bug. Thank you.

Done. Thanks!
Flags: needinfo?(itiel_yn8)
You need to log in before you can comment on or make changes to this bug.