DNS: host lookup times out before demand-dialing completes

VERIFIED DUPLICATE of bug 64857

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 64857
16 years ago
15 years ago

People

(Reporter: Jim Bray, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Using current mozilla or galeon, I reliably get a
'<host> could not be found...' error if the ppp link is
down and needs to demand-dial, as the demand-dial connection
seems to take about 5 seconds longer than mozilla/gecko wants
to wait.

 I've tried fixing this with the following prefs:

user_pref("network.http.connect.timeout", 999);
user_pref("network.http.request.max-start-delay", 999);
user_pref("network.http.request.timeout", 999);

with no luck. If there is a pref specifically for DNS query
timeout, please tell me about it, and if not, one would
be appreciated.

  I get the same behavior with old Netscape. I don't think it
is system-related, as if I do a host -s <big number>, host waits
long enough for the request to complete. Otherwise it times out also.

Comment 1

16 years ago
The underlying problem has to do with mozilla "fixating" on the pre-connection
DNS servers, and not recovering.
Whiteboard: dupeme
(Reporter)

Comment 2

16 years ago
 This would be consistent with the behavior I'm seeing, as it seems to time
out just after the ppp connnection is made, at which point changes in 
IP addresses and routing take place.

Comment 3

16 years ago
Related: bug 151683, bug 117628, bug 64857

Reporter: Do you still have the problem with Mozilla 1.1alpha?
(Reporter)

Comment 4

16 years ago
  This behavior seems to have gone away at 1.0-pre<something>, about a month
or so ago. I don't have a box on the net to test with, but figured this
had been fixed, perhaps accidentally so.

Comment 5

16 years ago
Thanks

Duping to 64857, because of bug 133359 and because this bug isn't reproducable
anymore.

*** This bug has been marked as a duplicate of 64857 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme

Comment 6

15 years ago
VERIFIED/dupe.
Status: RESOLVED → VERIFIED
Summary: host lookup times out before demand-dialing completes → DNS: host lookup times out before demand-dialing completes
You need to log in before you can comment on or make changes to this bug.