Closed Bug 1416543 Opened 2 years ago Closed 2 years ago

gfx/layers/wr/WebRenderBridgeParent.cpp:108:3: error: 'profiler_register_thread' was not declared in this scope

Categories

(Core :: Graphics: WebRender, defect, P1)

Unspecified
FreeBSD
defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: jbeich, Assigned: jerry)

References

Details

(Keywords: regression, Whiteboard: [wr-reserve])

Attachments

(1 file)

On Tier3 platforms without GeckoProfiler (iOS, Linux non-x86, BSDs, Solaris) the build is broken because "GeckoProfiler.h" doesn't define profiler_{,un}register_thread[1]. To reproduce on Tier1 platforms before bug 1371159 is fixed one has to force `return None` in gecko_profiler()[2].

$ ./mach bootstrap
$ ./mach build
[...]
In file included from objdir/gfx/layers/Unified_cpp_gfx_layers11.cpp:2:
gfx/layers/wr/WebRenderBridgeParent.cpp:108:3: error: use of undeclared identifier
      'profiler_register_thread'
  profiler_register_thread(name, &stackTop);
  ^
gfx/layers/wr/WebRenderBridgeParent.cpp:114:3: error: use of undeclared identifier
      'profiler_unregister_thread'; did you mean 'gecko_profiler_unregister_thread'?
  profiler_unregister_thread();
  ^~~~~~~~~~~~~~~~~~~~~~~~~~
  gecko_profiler_unregister_thread
gfx/layers/wr/WebRenderBridgeParent.cpp:112:1: note: 'gecko_profiler_unregister_thread'
      declared here
gecko_profiler_unregister_thread()
^
2 errors generated.

[1] https://searchfox.org/mozilla-central/rev/7fb4cc447c06/tools/profiler/public/GeckoProfiler.h#205
[2] http://searchfox.org/mozilla-central/rev/7fb4cc447c06/toolkit/moz.configure#26
Did you mean to use PROFILER_{,UN}REGISTER_THREAD instead per bug 1403868?
Flags: needinfo?(hshih)
$ echo "ac_add_options --enable-warnings-as-errors" >>.mozconfig # mimic MOZ_AUTOMATION
$ ./mach build
[...]
In file included from objdir/gfx/layers/Unified_cpp_gfx_layers11.cpp:2:
gfx/layers/wr/WebRenderBridgeParent.cpp:107:8: error: unused variable 'stackTop'
      [-Werror,-Wunused-variable]
  char stackTop;
       ^
1 error generated.
Sorry, I will fix this soon.
Assignee: nobody → hshih
Status: NEW → ASSIGNED
Pushed by hshih@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/046d8bdbc023
use the gecko profiler macro to register/unregister the thread name. r=me
It's just a trivial fix, so I just push it to inbound.
Flags: needinfo?(hshih)
Priority: -- → P1
Whiteboard: [wr-reserve]
https://hg.mozilla.org/mozilla-central/rev/046d8bdbc023
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Duplicate of this bug: 1416688
You need to log in before you can comment on or make changes to this bug.