Closed Bug 1416607 Opened 2 years ago Closed 2 years ago

Crash in [@ mozilla::gfx::RecordedScaledFontCreationByIndex::PlayEvent const ]

Categories

(Core :: Graphics: WebRender, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- fixed

People

(Reporter: darkspirit, Assigned: lsalzman)

References

(Blocks 2 open bugs)

Details

(Keywords: crash, nightly-community, Whiteboard: [wr-reserve] [gfx-noted])

Crash Data

Attachments

(1 file)

Seen on Socorro.

The one and only report so far:
bp-936cc8cc-0315-4cb1-a216-7bd270171107 (build 2017-11-06_100122)

(bug 1415609 was about blob-images + gpu-process on Linux. So this should be a different issue.)
(Could this have been fixed by bug 1412545 comment 16 or bug 1403198 comment 13?)
Lee a duplicate of bug 1412545 or bug 1403198?
Flags: needinfo?(lsalzman)
Priority: -- → P3
Whiteboard: [wr-mvp] [triage] → [wr-mvp] [triage][wr-reserve-candidate]
(In reply to Milan Sreckovic [:milan] from comment #2)
> Lee a duplicate of bug 1412545 or bug 1403198?

This is neither. Rather, as the metadata notes, this is an explicit gfxDevCrash() call that is signaling that the unscaled font it was looking for was not found. Somewhere earlier in the blob image playback, creation of an unscaled font failed to make it unavailable. So the underlying corruption/performance issues that were being dealt with in bug 1412545 and bug 1403198 remain fixed. This is a new and unique species of bug.
Flags: needinfo?(lsalzman)
Jeff, this one looks a little strange. I can't see a distinct reason that the unscaled font would fail to get added to mUnscaledFontTable unless for some bizarre reason RecordedUnscaledFontCreation was never played back. It looks like were there any other actual failure case, it would have caused us to hit a gfxDevCrash() earlier on, and yet we did not. I am not really sure where or how exactly we're failing to add the necessary unscaled font to the table here.
Flags: needinfo?(jmuizelaar)
Whiteboard: [wr-mvp] [triage][wr-reserve-candidate] → [wr-reserve]
OS: Mac OS X → All
Hardware: x86_64 → All
Duplicate of this bug: 1417292
Our going theory here is that some sort of allocation failure is causing NFR or UF to not get created. Rather than failing downwind, then in a random assert, better to at least signal the failure higher up. So let's put these errors here and see if this particular crash signature goes away in the playback before determining further actions with this bug.
Attachment #8928387 - Flags: review?(jmuizelaar)
Flags: needinfo?(jmuizelaar)
Attachment #8928387 - Flags: review?(jmuizelaar) → review+
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Priority: P3 → P1
Keywords: leave-open
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/da16d74f97e2
error when Moz2DImageRenderer fails to create a NativeFontResource or UnscaledFont. r=jrmuizel
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5c12713ef62f
follow-up - typo fix in error message. r=me
See Also: → 1418012
No longer blocks: stage-wr-trains
Severity: critical → normal
Priority: P1 → P3
Assignee: lsalzman → nobody
Status: ASSIGNED → NEW
Whiteboard: [wr-reserve] → [wr-reserve][wr-reserve-candidate]
Whiteboard: [wr-reserve][wr-reserve-candidate] → [wr-reserve]
Whiteboard: [wr-reserve] → [wr-reserve] [gfx-noted]
There have been no more reports of this particular signature since this landed. The only thing we are not seeing is the error message that was added in the patch here, which means our theory about NFRs not loading is seemingly correct. I'm going to close this out. If by some chance the signature does reappear, we can always reopen this later. However, for now, let's refer the particular instances of the new error message to bug 1418012 if it becomes something requiring deeper investigation.
Assignee: nobody → lsalzman
Status: NEW → RESOLVED
Closed: 2 years ago
Keywords: leave-open
Resolution: --- → FIXED
Priority: P3 → P1
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.