Layout is unable to handle X_DPI != Y_DPI

RESOLVED DUPLICATE of bug 64504

Status

()

Core
Layout
P3
major
RESOLVED DUPLICATE of bug 64504
16 years ago
15 years ago

People

(Reporter: Roland Mainz, Assigned: Marc Attinasi)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
[I am seeing this since a long time but I always forgot to file a bug for this:]
Our current layout+gfx code cannot handle the case when a device (framebuffer,
printer etc.) has a different resolution in the X direction than the resolution
in the Y resolution.
This causes various problems:
- We choose wrong fonts
- We are unable to support devices (like printers) which have X_DPI != Y_DPI
- [...insert more issues here...]

Suggested fix:
Split any occurence of DPI/resolution variables in one "X" and one "Y" variable
and handle the difference correctly.

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Future
(Reporter)

Comment 1

16 years ago
I can do this if someone from the layout/-group can make me a list which things
needs to be changed (AFAIK only layout/ and gfx/ need to be changed... or not ?)
...

Comment 2

16 years ago
Changing QA Contact
QA Contact: petersen → moied

Comment 3

16 years ago
duplicate of Bug 64504?
(Reporter)

Comment 4

16 years ago
Zac Jacobson wrote:
> duplicate of Bug 64504?

Bug 64504 may be DUP of this one since this bug has the better description... :)

*** This bug has been marked as a duplicate of 64504 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.