Switch devtools tests to async/await from Task.jsm/yield

RESOLVED DUPLICATE of bug 1365607

Status

P3
normal
RESOLVED DUPLICATE of bug 1365607
a year ago
8 months ago

People

(Reporter: arai, Assigned: arai)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

a year ago
separated from bug 1365607.

to make it easier to fix bug 1414177, it's better switching to async/await.
I'm going to fix tests first, and then devtools implementation.
(Assignee)

Comment 1

a year ago
sorry, I realized that there are some ongoing project about replacing devtools implementation,
so touching all of the existing tests might be overkill for the purpose of bug 1414177.
I'll re-think about the plan.
(might be better putting workaround there for now, and wait for the replacement)
Priority: -- → P3
We are close to have most of devtools codebase converted to async/await in bug 1365607 and its deps.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1365607

Updated

8 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.