OJI causes service manager leak

VERIFIED FIXED in M11

Status

Core Graveyard
Java: OJI
P1
normal
VERIFIED FIXED
19 years ago
8 years ago

People

(Reporter: vidur (gone), Assigned: edburns)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
It seems that the NSGetFactory for the OJI DLL maintains a reference to the
service manager
(http://lxr.mozilla.org/seamonkey/source/modules/oji/src/nsCJVMManagerFactory.cp
p#112) but never releases it. The resulting service manager leak results in many
more downstream leaks.
(Reporter)

Updated

19 years ago
Priority: P3 → P1
(Assignee)

Updated

19 years ago
Assignee: drapeau → edburns
(Assignee)

Comment 1

19 years ago
*** Bug 8178 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
Hmm... I don't understand why we need to cache a global reference to the service
manager. It is only used in one method, NSGetFactory().
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11
(Reporter)

Comment 3

19 years ago
Actually, it's used in other files in the same module (see JVM_GetJVMMgr(), for
example).
(Assignee)

Comment 4

19 years ago
How do I obtain a reference to the ServiceManager on demand?  There is no case
when I can release it so I could implement a strategy where I just re-obtain
and release it every time I need to use it.  Can I just save the
nsIServiceManager reference I receive from NSGetFactory()?
(Assignee)

Comment 5

19 years ago
Instead of asking for the ServiceManager and invoking methods from it, why
can't I just use nsServiceManeger static methods, as is done in all the files
returned in the query
 http://lxr.mozilla.org/mozilla/search?string=ServiceManager

Ed
(Assignee)

Comment 6

19 years ago
Created attachment 1783 [details] [diff] [review]
Fix for bug 14170
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

19 years ago
Warren beat me to the punch.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.