Closed Bug 1417049 Opened 2 years ago Closed 2 years ago

Can't install PWAs on Pixel C

Categories

(Firefox for Android :: General, defect, P1)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 59
Tracking Status
fennec + ---
firefox57 --- disabled
firefox58 --- verified
firefox59 --- fixed

People

(Reporter: u549602, Assigned: esawin)

References

(Blocks 1 open bug)

Details

(Keywords: qablocker)

Attachments

(1 file, 2 obsolete files)

Build: 58.0b3(Build 4)
Device: Pixel C (Android 8.0)

Steps to reproduce:

1. Go to https://pwa.rocks
2. Tap on continue in prompt.
3. Tap the "Add to home screen" badge shown in the toolbar.

Actual result: 
PWA is not installed and added to homescreen

Expected result: 
A shortcut is added on the homescreen and it opens the page in standalone mode.

For further details please check : 
https://www.youtube.com/watch?v=fpmpQSrZA8U&feature=youtu.be
Note: It's working on Android 8 phones as Google Pixel and Huawei Nexus 6P.
tracking-fennec: --- → ?
I just tested using Nightly (59) and latest beta https://ftp.mozilla.org/pub/mobile/candidates/58.0b3-candidates/build4/android-api-16/en-US/fennec-58.0b3.en-US.android-arm.apk

And it works... Please help confirm :)
Flags: needinfo?(mihai.ninu)
Sorry. Just tested on My O tablet. it didn't work.

Hi Snorp
I just tested on my Pixel C. 
There's no exception here
https://searchfox.org/mozilla-central/source/mobile/android/base/java/org/mozilla/gecko/util/ShortcutUtils.java#96
But the Add to home screen dialog is not displayed.
Could you please take a look?
Flags: needinfo?(mihai.ninu) → needinfo?(snorp)
Priority: -- → P1
Eugen, don't you have a Pixel C? Can you look at this?
Assignee: nobody → esawin
Flags: needinfo?(snorp)
Apparently, the default Google launcher on tablets doesn't support pinned shortcuts (ShortcutManager.isRequestPinShortcutSupported returns false).
On Chrome, the PWA is added to apps, but not pinned to the home screen, so it looks like it's failing to do that, too.
Summary: Can't install PWA's Android O tablet → Can't install PWAs on Pixel C
Not much we can do here if the launcher doesn't support it, but Fennec should probably show some kind of error.
Flags: needinfo?(wehuang)
I don't think this is a P1 at all if it only happens on the Pixel C. Even P2 seems high.
We should not show the page action for unsupported launchers.

(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #8)
> I don't think this is a P1 at all if it only happens on the Pixel C. Even P2
> seems high.

I assume it only happens on the Pixel C since it's the only tablet running Android 8 as of yet.
Attachment #8932616 - Flags: review?(cnevinchen)
We also need to remove "Add Page Shortcut" from the menu, I'm looking into it.
Remove "Add to Home Screen" options when launcher does not support pinned shortcuts.
Attachment #8932616 - Attachment is obsolete: true
Attachment #8932616 - Flags: review?(cnevinchen)
Attachment #8932626 - Flags: review?(cnevinchen)
Thanks Eugen! And agree w/ James this could be P2 or lower so please feel free to adjust it per need. (if you are fixing it for 59 we may leave it as P1?) Thanks.

(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #8)
> I don't think this is a P1 at all if it only happens on the Pixel C. Even P2
> seems high.

(In reply to Eugen Sawin [:esawin] from comment #11)
> Created attachment 8932626 [details] [diff] [review]
> 0001-Bug-1417049-1.1-Don-t-show-Add-to-Home-Screen-page-a.patch
> 
> Remove "Add to Home Screen" options when launcher does not support pinned
> shortcuts.
Flags: needinfo?(wehuang)
tracking-fennec: ? → +
Comment on attachment 8932626 [details] [diff] [review]
0001-Bug-1417049-1.1-Don-t-show-Add-to-Home-Screen-page-a.patch

The patch is great.
But maybe we also want to check it here as well
https://searchfox.org/mozilla-central/rev/9f3bd430c2b132c86c46126a0548661de876799a/mobile/android/base/java/org/mozilla/gecko/toolbar/PageActionLayout.java#171
Attachment #8932626 - Flags: review?(cnevinchen) → review+
Addressed comment.
Attachment #8932626 - Attachment is obsolete: true
Attachment #8932882 - Flags: review+
Pushed by esawin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4facc0b0613e
[1.2] Don't show Add to Home Screen page action for incompatible launchers. r=nechen
https://hg.mozilla.org/mozilla-central/rev/4facc0b0613e
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Please request Beta approval on this when you get a chance.
Flags: needinfo?(esawin)
Comment on attachment 8932882 [details] [diff] [review]
0001-Bug-1417049-1.2-Don-t-show-Add-to-Home-Screen-page-a.patch

Approval Request Comment
[Feature/Bug causing the regression]: Progressive Web Apps home screen shortcut.
[User impact if declined]: Add to home screen (PWA pinning) is offered in Fennec on unsupported systems.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: comment 0
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: It only hides UI elements by checking for system-specific support for this feature.
[String changes made/needed]: None
Flags: needinfo?(esawin)
Attachment #8932882 - Flags: approval-mozilla-beta?
Comment on attachment 8932882 [details] [diff] [review]
0001-Bug-1417049-1.2-Don-t-show-Add-to-Home-Screen-page-a.patch

PWA is shipped in 58. Beta58+.
Attachment #8932882 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Verified as fixed on the latest beta build, 58.0b15.
This issue was verified on the same device it was initially found.
Flags: qe-verify+
See Also: → 1465431
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.