Closed Bug 1417248 Opened 2 years ago Closed 2 years ago

Pinned tabs are too wide in compact mode

Categories

(Firefox :: Tabbed Browser, defect, P3)

57 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- wontfix
firefox58 --- fixed
firefox59 --- verified

People

(Reporter: c4609174, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image pinnedTabWidth.png
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171030111120

Steps to reproduce:

Upgraded to Firefox 57 (with Fedora 27). I also changed the setting in the customization to use the "compact" mode.


Actual results:

The icons of the websites are square ones, but the rectangular tabs, which are meant to save space, have a big width. In touch mode this may make sense, but not in the compact mode.

Compared to Australis the width of these tabs did increase, although the "heavy stylistic elements" of Australis' curved tabs were removed. So one would have expected these pinned tabs to have a smaller width too, but no…


Expected results:

Let these icons to be square and do not add empty space around these pinned tabs. For the "usual" tabs everything looks good/okay, but not for these pinned tabs. They really have a big width.

Also note that pinned tabs are often used to pin services/websites, which should stay open and are known to the user, are frequently used and should only be one click away. That's the whole reason why they only show the icon.
So they do not need all this empty space surrounding them. 

Additionally they can/may be a lot and when you have only 4 tabs open already 1/7th of the width of my 1920x1080px screen are used for these. And 4 ones are not a lot, IMHO.
Component: Untriaged → Tabbed Browser
Assignee: nobody → dao+bmo
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: regression
OS: Unspecified → All
Hardware: Unspecified → All
Summary: Pinned tabs in photon are too width → Pinned tabs are too wide in compact mode
Depends on: 1354332
Priority: -- → P3
Comment on attachment 8928493 [details]
Bug 1417248 - Make pinned tabs smaller in compact mode.

https://reviewboard.mozilla.org/r/199750/#review205386

Works for me, thanks!
Attachment #8928493 - Flags: review?(jhofmann) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4417906600fb
Make pinned tabs smaller in compact mode. r=johannh
https://hg.mozilla.org/mozilla-central/rev/4417906600fb
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Uuugh, what? Can only see text at your link… https://screenshots.firefox.com/aFEhmqJRGDO3jSkX/screenshots.mattn.ca

But BTW, anyway, thanks for fixing that so fast!
I have reproduced this bug with Nightly 59.0a1 (2017-11-14) on Windows 8.1 , 64 Bit ! 

This bug's fix is Verified with latest Nightly !

Build   ID    20171121100129
User Agent    Mozilla/5.0 (Windows NT 6.3; WOW64; rv:59.0) Gecko/20100101 Firefox/59.0
QA Whiteboard: [bugday-20171115]
Status: RESOLVED → VERIFIED
Comment on attachment 8928493 [details]
Bug 1417248 - Make pinned tabs smaller in compact mode.

Approval Request Comment
[Feature/Bug causing the regression]: Firefox 57 theme and compact mode
[User impact if declined]: see comment 0
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: simple fix
[String changes made/needed]: /
Attachment #8928493 - Flags: approval-mozilla-beta?
Comment on attachment 8928493 [details]
Bug 1417248 - Make pinned tabs smaller in compact mode.

Polish a pinned tabs issue in compact mode. Beta58+.
Attachment #8928493 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I have reproduced this bug with Nightly 59.0a1 (2017-11-14) on Windows 10 pro , 64 Bit ! 

This bug's fix is Verified with latest Beta !

Build   ID : 20171123161455
User Agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
QA Whiteboard: [bugday-20171115] → [bugday-20171122]
You need to log in before you can comment on or make changes to this bug.