behavior of the webRequest API does not match the documentation

RESOLVED DUPLICATE of bug 1477696

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 1477696
2 years ago
2 months ago

People

(Reporter: earthlng, Assigned: wbamberg)

Tracking

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20171107091003

Steps to reproduce:

"If two extensions listen to onHeadersReceived for the same request, then the second listener will see modifications made by the first listener, and will be able to undo any changes made by the first listener." is not what's happening in Nightly 58

Also see https://github.com/ghacksuserjs/ghacks-user.js/issues/265


Actual results:

The second listener does NOT see modifications made by the first listener.


Expected results:

the second listener *should* see modifications made by the first listener. The third listener should see modifications made by the first and second listener etc.
Component: Untriaged → WebExtensions: Request Handling
Product: Firefox → Toolkit
Component: WebExtensions: Request Handling → Add-ons
Product: Toolkit → Developer Documentation
Version: 58 Branch → unspecified
Assignee: nobody → wbamberg
Priority: -- → P2
Duping this to bug 1477696, we need to figure out the right behavior first, then document.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1477696
You need to log in before you can comment on or make changes to this bug.