Videos show in distorted colors (e.g. Youtube)

RESOLVED DUPLICATE of bug 1417442

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1417442
7 days ago
2 days ago

People

(Reporter: Dan Wolff, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 days ago
Created attachment 8928314 [details]
Youtube video displaying the issue

OS: Windows 8.1
Firefox versions tested:
- 59.0a1 (2017-11-14), 64bit
- 57.0, 64bit

Steps to reproduce:
- View a video (tested on youtube.com, vimeo.com, imgur.com, bbc.com)

Actual results:
- Distortions seeming to separate magenta and green (see screenshot)

Expected results:
- Normal colors


Other investigation:
- Restarting in safe mode *DOES* fix the problem
- The Firefox screenshot feature *DOES* show normal colors
- Using a clean profile does *NOT* change the results
- Disabling plugins Cisco OpenH264 and Widevine does *NOT* change the results
(Reporter)

Comment 1

7 days ago
Created attachment 8928315 [details]
about-support.json
Please make sure you have the latest graphics driver: https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
Component: Untriaged → Graphics
Product: Firefox → Core
Component: Graphics → Audio/Video: Playback
Duplicate of this bug: 1417544
Can you try setting media.wmf.use-nv12-format to false and see if that fixes the issue?

thank you
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1417442
(Reporter)

Comment 5

2 days ago
Setting "media.windows-media-foundation.use-nv12-format" to false fixes the issue.

It has also been fixed in the latest nightly.
You need to log in before you can comment on or make changes to this bug.