Open Bug 1417276 Opened 2 years ago Updated 6 months ago

Tabs unable to move to another monitor on top Discord

Categories

(Firefox :: Tabbed Browser, defect, P3)

57 Branch
defect

Tracking

()

UNCONFIRMED

People

(Reporter: jacobwrig, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171112125346

Steps to reproduce:

I had Discord open on another monitor maximized and tried moving a tab from one monitor on top of where discord is located.

I have not been able to replicate it with other application open.


Actual results:

The tab stayed put in the current window and did not move over to the other monitor.


Expected results:

The tab should have moved to the other monitor.
Component: Untriaged → Tabbed Browser
Ditto, happening on nightly and stable as of today. Seems to only happen with the Discord desktop app as well as the web app when open in Chrome but not in Firefox Nightly. Dragging the tab over Discord causes nothing to happen, but anywhere else the tab is moved as normal (including over Chrome UI when running the web app).


This looks related to the "dragover" event as it's handled in chromium perhaps.

Simple repro for this behavior, open the following in Chrome, and drag a firefox tab over it. The firefox tab will not be moved or anything.

<!DOCTYPE html>
<html>
<head>
    <script type="text/javascript">
        window.onload = function() {

            var body = document.getElementsByTagName("html")[0];
            body.addEventListener("dragover", function(event) {
                event.preventDefault();
            }, false);
        };
    </script>
</head>
<body>
</body>
</html>
Sounds like this is a Discord bug.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
Filed https://crbug.com/792795, but am curious if there is not a resolution firefox can do, as firefox is what ends up with the broken experience
Also, of note, Firefox has the exact same behavior, opening the repro page in firefox, and dragging e.g. edge tabs onto firefox causes the same issues chrome does.
(In reply to khazhy from comment #3)
> Filed https://crbug.com/792795, but am curious if there is not a resolution
> firefox can do, as firefox is what ends up with the broken experience

I don't think it's a Chrome bug either.

Why is this code calling preventDefault for the dragover event in the first place?
Its needed for drag-and-drop.

See example on https://developer.mozilla.org/en-US/docs/Web/Events/dragover
Still not sure I understand this bug, but reopening for now.

Is this a regression, i.e. did this work in older versions of Firefox?
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(khazhy)
Priority: -- → P3
Resolution: INVALID → ---
Some updates:

Friend tried this on W8.1 on FF56-58, all had the bug as described using the reproducer described above. I don't have reason to believe this has worked in the past.

This seems Windows specific, as I cannot reproduce this behavior on OSX, although I haven't tested on Linux. My most educated guess is the web page on Chrome/etc. consumes the OS drop event so Firefox results in not opening a tab.
Flags: needinfo?(khazhy)
Want to confirm I am also having the same issue however, it happens to me with just one monitor. As in if I have discord open on one half of the screen I can't drop FF tabs on top of that window.

This is still an issue and affects me every day because I very often have discord maximized on my 2nd monitor. It results in us needing to drag the tab twice to get it into the position we want it.

You need to log in before you can comment on or make changes to this bug.