Closed Bug 1417316 Opened 3 years ago Closed 3 years ago

[Form Autofill] Can not preview or fill in data when triggering suggestion dropdown twice

Categories

(Toolkit :: Form Autofill, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla59
Tracking Status
firefox58 --- verified
firefox59 --- verified

People

(Reporter: lchang, Assigned: lchang)

References

(Blocks 1 open bug)

Details

(Whiteboard: [form autofill:MVP])

Attachments

(1 file)

[Steps:]

0. Have at least one credit card record saved.

1. Open a website with a credit card form (e.g. https://luke-chang.github.io/autofill-demo/basic_cc.html)
2. Focus any credit card related input field (e.g. Card Holder Name)
3. Click the input to trigger the suggestion dropdown
4. Click the input again to dismiss the suggestion dropdown
5. Click the input once again to trigger the suggestion dropdown again
6. Try to hover items to preview or click items to fill in


[Actual Result:]

Can not preview or fill in data.


[Expected Result:]

Should preview and fill in data as normal.
Note that it affects Address Autofill as well.
Assignee: nobody → lchang
Status: NEW → ASSIGNED
See Also: → 1413473
It's a regression caused by bug 1413473. Fortunately, Ray implemented two solutions in that bug and the second one, which causes this bug, is actually a backup plan that can be removed safely. I'll remove that and also verify bug 1413473.
Comment on attachment 8928439 [details]
Bug 1417316 - [Form Autofill] Do not clear the cached autocomplete result when popup closed as it might be reused.

https://reviewboard.mozilla.org/r/199692/#review204778

Thanks!
Attachment #8928439 - Flags: review?(ralin) → review+
Pushed by lchang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7cf44ad5d5d4
[Form Autofill] Do not clear the cached autocomplete result when popup closed as it might be reused. r=ralin
Comment on attachment 8928439 [details]
Bug 1417316 - [Form Autofill] Do not clear the cached autocomplete result when popup closed as it might be reused.

Approval Request Comment
[Feature/Bug causing the regression]: Regression caused by bug 1413473
[User impact if declined]: Form Autofill can neither preview data nor fill in data
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: Yes. Tested locally.
[Needs manual test from QE? If yes, steps to reproduce]:  Yes. STR is in comment 0.
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No.
[Why is the change risky/not risky?]: It contains one line which only affects Form Autofill add-on
[String changes made/needed]: N/A
Attachment #8928439 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/7cf44ad5d5d4
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Hi Brindusa, could you help find someone to verify if this issue was fixed as expected on the latest Nightly build? Thanks!
Flags: needinfo?(brindusa.tot)
Change NI to Gabi.
Flags: needinfo?(brindusa.tot) → needinfo?(gasofie)
Verified as fixed with 59.0a1 20171116100106 on Windows 10x64, Ubuntu 14.4 and MacOS 10.12.6
Flags: needinfo?(gasofie)
Comment on attachment 8928439 [details]
Bug 1417316 - [Form Autofill] Do not clear the cached autocomplete result when popup closed as it might be reused.

Issue fixed and verified. Beta58+.
Attachment #8928439 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified as fixed using 58.0b5 20171120142222 on Win 10x64, Ubuntu 14.4 and MacOS 10.12.6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.