favicons on the bookmark bar and bookmarks have a black background to them

VERIFIED WORKSFORME

Status

()

Firefox
Bookmarks & History
VERIFIED WORKSFORME
2 months ago
2 months ago

People

(Reporter: chris.virostek, Unassigned)

Tracking

({regression, regressionwindow-wanted})

57 Branch
regression, regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(Reporter)

Description

2 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171112125346

Steps to reproduce:

Drag favicon from address bar to bookmark bar. 


Actual results:

Variety of favicons placed on bookmark bar have black backgrounds. Some also appear replaced with a different favicon.


Expected results:

The correct favicon should have been placed on the bookmark bar.

Comment 1

2 months ago
I'm seeing the black background as well - seems to happen with "dynamic-content" favicons (e.g. those displaying badges with a count/status overlay: GitLab, Whatsapp...).

Updated

2 months ago
Component: Untriaged → Bookmarks & History
Keywords: regression, regressionwindow-wanted

Updated

2 months ago
status-firefox57: --- → affected

Comment 2

2 months ago
This might be bug 1401851 or bug 1401777.  Could people experiencing this problem please try in the latest Nightly?  Both those bugs have been fixed on Nightly.

If they're not the problem, then maybe this is due to bug 492172 and its related bugs?  Thinking especially: bug 977177, bug 1360477, bug 1283825, bug 1362394, bug 798223

Comment 3

2 months ago
I'm sorry but we need better steps to be able to reproduce the bug, please provide uris of pages that when dragged to the toolbar cause a black icon.
Part of the bugs relative to "different" favicon are fixed in Firefox 58.
Flags: needinfo?(chris.virostek)
(Reporter)

Comment 4

2 months ago
Thank you Drew Willcoxon. I just recently tried the nightly and the problem I reported here is resolved. 

Marco bonardo - sites favicons giving black backgrounds were ign, giantbomb, IMBD, wowhead, gamespot, and others.
Flags: needinfo?(chris.virostek)

Comment 5

2 months ago
I tried those pages, the only two still different in Nightly are giantbomb and wowhead, that show a different icon in the tab. That's because they only provide a 16x16 icon that is unsuitable for hi dpi screens, so we end up using the rich icon.

Based on this and commtn 4, I'm marking this as WFM for Nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME

Comment 6

2 months ago
Checked both https://web.whatsapp.com/ and https://gitlab.com/ favicons (the ones I noticed with the odd background) in Nightly 59.0a1 and they're looking fine again. Thx!

Comment 7

2 months ago
Thank you for reporting back!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.