Closed Bug 1417387 Opened 3 years ago Closed 3 years ago

TypeError: 'unicode' does not have the buffer interface

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(firefox59 fixed)

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: florian, Assigned: gps)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

$ ./mach build
Error running mach:

    ['build']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

TypeError: 'unicode' does not have the buffer interface

  File "/Users/florian/buildhg/mozilla/python/mozbuild/mozbuild/mach_commands.py", line 170, in build
    mach_context=self._mach_context)
  File "/Users/florian/buildhg/mozilla/python/mozbuild/mozbuild/controller/building.py", line 1128, in build
    keep_going=keep_going)
  File "/Users/florian/buildhg/mozilla/python/mozbuild/mozbuild/controller/building.py", line 1337, in _run_client_mk
    if self._check_clobber(mozconfig, os.environ):
  File "/Users/florian/buildhg/mozilla/python/mozbuild/mozbuild/controller/building.py", line 1381, in _check_clobber
    clobber_output)
  File "/Users/florian/buildhg/mozilla/python/mozbuild/mozbuild/controller/clobber.py", line 192, in maybe_do_clobber
    print('Automatically clobbering %s' % self.topobjdir, file=fh)


$ python --version
Python 2.7.13
$ python3 --version
Python 3.6.3
$ cat mozconfig
mk_add_options AUTOCLOBBER=1
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-browser


Moving away the obj directory by hand worked.
Assignee: nobody → gps
Blocks: 1412398
Status: NEW → ASSIGNED
Component: mach → Build Config
Depends on: 1416052
Comment on attachment 8928634 [details]
Bug 1417387 - Don't mix unicode and bytes in clobber code;

https://reviewboard.mozilla.org/r/199868/#review204982

Gah, so hard to deal with these issues in Python 2.
Attachment #8928634 - Flags: review+
Attachment #8928634 - Flags: review?(core-build-config-reviews)
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/62b191e02145
Don't mix unicode and bytes in clobber code; r=nalexander
Duplicate of this bug: 1417623
https://hg.mozilla.org/mozilla-central/rev/62b191e02145
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.