Closed Bug 1417396 Opened 3 years ago Closed 3 years ago

MacOS titlebar renders differently in default and lightweight themes.

Categories

(Firefox :: Theme, defect, P5)

57 Branch
All
macOS
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox57 --- wontfix
firefox58 --- wontfix
firefox59 --- wontfix
firefox60 --- wontfix
firefox61 --- fix-optional

People

(Reporter: webber59, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171112125346

Steps to reproduce:

1. Enable the titlebar (hamburgermenu > customize toolbar > check titlebar)
1. Install a lightweight theme, or the default Light or Dark themes


Actual results:

The titlebar keeps the Mac system color, the lightweight theme is only visible in the tab, tool and bookmarks bars.


Expected results:

The theme background should be visible in the titlebar as well as in tabs, toolbar, bookmarks bar
Additional info:
- This didn’t happen in Firefox 54. See the attached image for comparisons.
- I use Mac OS X Yosemite 10.10.5
Component: Untriaged → Theme
OS: Unspecified → Mac OS X
Blocks: 1392219
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Priority: -- → P5
I can reproduce this bug on Windows 10 x64 as well.
OS: Mac OS X → All
(In reply to Oana Botisan from comment #2)
> I can reproduce this bug on Windows 10 x64 as well.

You're talking about bug 1381004. I can understand that this would seem like the same issue to you, but the underlying issues are vastly different between the two platforms, so it doesn't really make sense to track them in a single bug. :)
Flags: qe-verify+
OS: All → Mac OS X
Hardware: Unspecified → All
See Also: → 1381004
Summary: Titlebar renders differently in default and lightweight themes. → MacOS titlebar renders differently in default and lightweight themes.
Duplicate of this bug: 1428547
To come back to this, I believe the original issue was that we weren't able to change the dark titlebar text to be lighter when dealing with e.g. the default theme, which has a dark titlebar. I don't remember whether we fully exhausted our options here or if this was just dropped in favor of more important Photon work.

Markus, on the off chance, is there a way we can change the native OSX titlebar text color, save from drawing the entire titlbar ourselves (bug 1381004)?

Thanks!
Flags: needinfo?(mstange)
Attached image screenshot_249.png
If it's not possible to draw the titlebar text lighter, what about having the theme draw in the titlebar as long as it's not a dark theme?

In Thunderbird 57 we had Photon tabs but themes still drew in the titlebar, which looked quite nice, see the attachment. The new version in 58/59 is a bit ugly in comparison. 

Most people have the titlebar on in Thunderbird not because they want to see the titlebar text, but just because they choose mail.tabs.autohide, to hide the tab when there's only one, which forces the titlebar on. Also the default theme isn't dark.
(In reply to Johann Hofmann [:johannh] from comment #5)
> Markus, on the off chance, is there a way we can change the native OSX
> titlebar text color, save from drawing the entire titlbar ourselves (bug
> 1381004)?

Only with extreme contortions in the widget code, which I'd really prefer to avoid.
Flags: needinfo?(mstange)
Maybe a hidden preference to get the old behaviour back then? Most themes work fine with it, and it looks so much better.
(In reply to Elhem Enohpi from comment #8)
> Maybe a hidden preference to get the old behaviour back then? Most themes
> work fine with it, and it looks so much better.

Yes, I think we'd take a patch for this, but I doubt anyone from the Firefox team is going to work on it for now.
We've decided this is the way we want the titlebar to look. Hence, invalid.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.