Closed Bug 1417408 Opened 4 years ago Closed 4 years ago

Disabled developer tools installed by an add-on comes back enabled on re-open

Categories

(WebExtensions :: Developer Tools, defect, P5)

57 Branch
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1394750

People

(Reporter: closingin, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171114144214

Steps to reproduce:

I disabled the HTTPS Everywhere developer tools (which worked), closed the tools panel, and re-opened it again.


Actual results:

The HTTPS Everywhere developer tools was enabled again.


Expected results:

It should remain disabled.
Severity: normal → minor
Component: Untriaged → Developer Tools
Component: Developer Tools → WebExtensions: Developer Tools
Product: Firefox → Toolkit
After digging a little bit, it seems that whenever you open the devtools panel and disable an add-on based devtool, it appends a new entry with a (random ?) number in its name saying that the devtool is disabled.

This number appears apparently as : devtools.webext-extension-name_organisation_name-[random-number]-0-0-devtools-panel.enabled

The problem is that if you close and re-open the panel, the number isn't the same anymore so it cannot know if the devtool is disabled or not.
Priority: -- → P5
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1394750
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.