Closed Bug 1417529 Opened 2 years ago Closed 2 years ago

Flickering content on psarips.com

Categories

(Core :: Graphics, defect)

All
Windows
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla59
Tracking Status
firefox58 --- fixed
firefox59 --- verified
firefox60 --- verified

People

(Reporter: jimm, Assigned: mattwoodrow)

References

Details

Attachments

(2 files)

STR:

1) load psarips.com
2) drag your cursor over the panels in content 

result: flickering 
expected: probably some sort of css transition
This is due to retain-dl.Disabling retain-dl will not repro this.
This bug should block bug 1352499
Flags: needinfo?(matt.woodrow)
Blocks: 1352499
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
Attachment #8929209 - Flags: review?(mikokm)
The overflow areas relative to self for frames within a preserve-3d context don't include 3d content, so are pretty meaningless.

The post-transform overflow for the root is the only one that includes everything properly, so let's move currentFrame up to the parent of that, and use the overflow relative to parent to get something meaningful.
Attachment #8929211 - Flags: review?(mikokm)
Comment on attachment 8929211 [details] [diff] [review]
Part 2: Propagate invalidations with a 3d context up to the root, since we don't have valid overflow areas for except for the post-transform overflow on the 3d context root. r=miko

Review of attachment 8929211 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/painting/RetainedDisplayListBuilder.cpp
@@ +635,5 @@
>      nsRect overflow = f->GetVisualOverflowRectRelativeToSelf();
>      nsIFrame* currentFrame = f;
>  
>      while (currentFrame != mBuilder.RootReferenceFrame()) {
> +

Can you add a comment here about what is happening?
Attachment #8929211 - Flags: review?(mikokm) → review+
Comment on attachment 8929209 [details] [diff] [review]
Part 1: Make sure UpdateBounds actually takes effect for transform separator items.

Review of attachment 8929209 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8929209 - Flags: review?(mikokm) → review+
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f29736084610
Part 1: Make sure UpdateBounds actually takes effect for transform separator items. r=miko
https://hg.mozilla.org/integration/mozilla-inbound/rev/935f5a2f8b11
Part 2: Propagate invalidations with a 3d context up to the root, since we don't have valid overflow areas for except for the post-transform overflow on the 3d context root. r=miko
https://hg.mozilla.org/mozilla-central/rev/f29736084610
https://hg.mozilla.org/mozilla-central/rev/935f5a2f8b11
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Comment on attachment 8929209 [details] [diff] [review]
Part 1: Make sure UpdateBounds actually takes effect for transform separator items.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1352499. This is code that is preffed off, but we want to run a shield study enabling the pref.
[User impact if declined]: None, preffed off code.
[Is this code covered by automated tests?]: Yes, when the pref is enabled.
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Code is preffed off.
[String changes made/needed]: None
Attachment #8929209 - Flags: approval-mozilla-beta?
Comment on attachment 8929209 [details] [diff] [review]
Part 1: Make sure UpdateBounds actually takes effect for transform separator items.

Take this to support the shield study in 58. Beta58+.
Attachment #8929209 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [good first verify]
I have reproduced this bug with Nightly 59.0a1 (2017-11-15) on Windows 10, 64 Bit!

This bug's fix is verified with latest Release & latest Beta!

Build ID   : 20180128191252
User Agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0


Build ID   : 20180128191456
User Agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
QA Whiteboard: [good first verify] → [good first verify] [bugday-20180124]
I have successfully reproduced this issue on Firefox Nightly 59.0a1 (2017-11-15) under Windows 10 (x64) using the steps from Comment 0.

The issue is no longer reproducible on Firefox 59 RC and Firefox Nightly 60.0a1 (2018-03-12) under Windows 10 (x64), Ubuntu 16.04 (x64) and macOS 10.12.6.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.