Closed Bug 1417584 Opened 4 years ago Closed 4 years ago

JPEG images dragged to file manager are saved as JFIF

Categories

(Firefox :: File Handling, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1389836
Tracking Status
firefox59 --- fixed

People

(Reporter: gingerbread_man, Unassigned)

Details

(Keywords: reproducible)

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
20171115100050

Steps to reproduce:
1. https://upload.wikimedia.org/wikipedia/commons/thumb/5/50/RedPandaFullBody.JPG/800px-RedPandaFullBody.JPG
2. Left-click and drag the image somewhere like the desktop.

Actual results:
The file saved is 800px-RedPandaFullBody.jfif

Expected results:
The file saved should be 800px-RedPandaFullBody.JPG


Also, if I right-click the image and choose Save Image As…, "Save as type" is blank. If I click to expand it, there's a blank entry, then an "All files" entry. I don't know if I should file a separate report for that, or if it's the same issue.

It's worth noting that these issues have cropped up in the past, e.g. bug 414201 and bug 586795.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1389836
You need to log in before you can comment on or make changes to this bug.