Closed Bug 1417650 Opened 2 years ago Closed 2 years ago

Opening a home screen shortcut no longer selects already existing tab

Categories

(Firefox for Android :: General, defect, P2)

All
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 59
Tracking Status
firefox57 --- unaffected
firefox58 --- fixed
firefox59 --- fixed

People

(Reporter: JanH, Assigned: jchen)

References

Details

(Keywords: regression)

Attachments

(1 file)

If a user opens a tab through a home screen shortcut and stays within the same domain, then clicking that shortcut again should select that existing tab instead of opening a new one.

This was already broken if Firefox wasn't already running when clicking the shortcut again (bug 1249318), but now it also happens even when Firefox is still alive.
Summary: Opening a home screen short cut no longer selects already existing tab → Opening a home screen shortcut no longer selects already existing tab
I haven't had the time to look at this more closely, but could this be another fallout of your GeckoView changes there?
Flags: needinfo?(nchen)
Jim can you see if this is a regression from the recent refactoring
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1341615
Part of bug 1341615 is almost certainly in fact bug 1249318. Other than that I clearly remember things were still working fine when I fixed bug 1407188, so this is a recent regression and can't be a duplicate.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: nobody → nchen
Status: REOPENED → ASSIGNED
Flags: needinfo?(nchen)
Pass in the flag names for Tab:OpenUri so we don't have to worry about
synchronizing the flags in Java with ones in C++. r=me for trivial
patch.
Attachment #8930173 - Flags: review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/11c2b9599151
Correctly specify flags for Tab:OpenUri; r=me
https://hg.mozilla.org/mozilla-central/rev/11c2b9599151
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Comment on attachment 8930173 [details] [diff] [review]
Correctly specify flags for Tab:OpenUri (v1)

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1412872
[User impact if declined]: Home screen shortcuts fail to switch to existing tabs
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Small patch that only addresses fallout from bug 1412872
[String changes made/needed]: None
Attachment #8930173 - Flags: approval-mozilla-beta?
Comment on attachment 8930173 [details] [diff] [review]
Correctly specify flags for Tab:OpenUri (v1)

Take this for users who rely on mouse gestures. It's behind a pref and it's off by default. Beta58+.
Attachment #8930173 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 8930173 [details] [diff] [review]
Correctly specify flags for Tab:OpenUri (v1)

Fix a regression that home screen shortcuts fail to switch to existing tabs. Beta58+.
Flags: qe-verify+
tracking-fennec: ? → +
Tested with HTC 10 (Android 7.0) and Huawei Honor (Android 5.1.1) on Nightly build from 12/13.
STR:
1.add page shortcut cnn.com;
2.have two tabs opened on Nightly, one with cnn (page shortcut) and youtube.
3.put the Nightly in background with focus on youtube.
4.tap on page shortcut.
Actual results: another tab with cnn.com is loaded.
Also, another behavior but couldn't reproduce all the time: tapping on page shortcut opened youtube not cnn.com. Is something I missed? Thanks
Status: RESOLVED → VERIFIED
tracking-fennec: + → ---
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.