Firefox Quantum eating RAM while even not used

RESOLVED INCOMPLETE
(NeedInfo from)

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
2 months ago
17 days ago

People

(Reporter: me, Unassigned, NeedInfo)

Tracking

58 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36

Steps to reproduce:

1. install firefox quantum
2. open one tab
3. measure ram usage during few hours while firefox is not used


Actual results:

Firefox is using more and more ram over time. And if I open some other heavier website it uses enormous amount of ram (>1gb)


Expected results:

Lower ram usage as in other browsers. See the pictures attached where I compared Chrome, Safari and Firefox https://imgur.com/a/PjhWd In the last picture there is memory tab opened, gfx part is rising over time
It's probably due to one of your extensions. Please troubleshoot with Safe Mode: https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode
(Reporter)

Comment 2

2 months ago
Kohei, I had 2 plugins installed (lastpass and vuejs plugins), but I had them disabled because I also suspected plugins was the issue. But even if they are, if desabled they should not make problems, right?
Anyhow, I removed plugins and done the same thing : 
steps : 
1.vanilla firefox quantum install without anything added
2.open google search for firefox
3.leave it in background for a few hours

results : 
Firefox rose from ~250mb at start to around 700 by activity monitor and less by firefox about:memory page (and it rose there too over time).
Relevant screenshot https://imgur.com/a/Y0ftv

I`ll try in safe mode also.
Tested on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0 ID:20171112125346 and 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0 and could not reproduce the issue.
Additional Notes:
- Firefox process started with ~300 MB memory in use and after ~2hours, the process was using below 300 MB memory(~250MB) via activity monitor (with google search for Firefox as instructed in bug description)
- CPU usage under 1%, in idle, during testing
─ 10.54 MB (06.48%) -- GFX usage - live measurement  - after 2 hours

me@ssijak.com Please try to reproduce the issue using Safe Mode as Kohei Yoshino suggested and let us know the result please. Thank you
Flags: needinfo?(me)

Comment 4

17 days ago
(In reply to Deac Alin-Desktop Engineering QA from comment #3)
> ...
> me@ssijak.com Please try to reproduce the issue using Safe Mode as Kohei
> Yoshino suggested and let us know the result please. Thank you

Reporter seems to be gone
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 days ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.