Closed Bug 1417990 Opened 2 years ago Closed 2 years ago

Web shortcuts on windows are an icon on a black page on windows since 57, should probably be white as it used to be

Categories

(Firefox :: Theme, defect, P2)

Unspecified
Windows
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- wontfix
firefox58 --- affected
firefox59 --- affected

People

(Reporter: pascalc, Unassigned)

References

Details

Attachments

(1 file)

This is a bug reported by a 57 user on the French community forums (https://forums.mozfr.org/viewtopic.php?f=5&t=135331), the web shortcuts for pages on Windows now have a black background, behind our logo, it was white up to 56 and it is probably not intentional since the default shortcuts on windows are all white.

Here is a link to a screenshot provided by the user:
http://www.hostingpics.net/viewer.php?id=232489firefox.jpg

I could reproduce this bug by creating a web shortcut on the desktop (Firefox not installed), install 56 and see it change to our logo on a white background and then upgrade to 57 and the background becomes black.

I put screenshots online to show these 3 steps:

Default Windows Web shortcut:
https://www.chevrel.org/screenshot/bugs/shortcutFx57/WebShortcutBeforeFx.png

Shortcut with 56 intalled:
https://www.chevrel.org/screenshot/bugs/shortcutFx57/WebShortcutFx56Installed.png 

Shortcut after 56 updated to 57:
https://www.chevrel.org/screenshot/bugs/shortcutFx57/WebShortcutFxUpdatedto57.png
Matt, do you know if this was intentional, and/or what would cause this?
Flags: needinfo?(mhowell)
This is an intentional change that was made along with rest of the branding/logo changes in bug 1399691; the icon you're seeing is browser/branding/official/document.ico, which includes the background art and was replaced along with the rest of the icons there.

Is the issue just that the dark background makes the shortcut look different from the default? Or is there some other disadvantage to it?
Component: Untriaged → Theme
Flags: needinfo?(mhowell)
From the user point of view, it looks bad, I am an occasional windows user but I can see how it can be seen as a bug since the symbol used is a sheet of paper and paper is white not black
Blocks: 1399691
Priority: -- → P2
I find it a little more interesting that they seem to be seeing _both_ at the same time.

That implies to me that either Windows has some broken icon caching (which is not surprising), or that the white icons are coming from somewhere else (e.g. does Windows ever construct one itself from putting the app icon over a generic document icon?)

Original screenshot says the black icons are .HTM, and the white is .PHP.
Windows definitely does has some broken icon caching, we've run into it before, but Windows 7 does generate icons in the way you describe, by putting the application icon over a blank white "document" background; I think Win10 doesn't do that anymore, or at least I can't get it to.
It's also possible that 56 and 57 are both installed and have different associations in that screenshot.
shorlander: a black "page" does seem a slightly strange choice; can you shed more light on the reasoning here?

Gerv
Flags: needinfo?(shorlander)
This new icon with dark/black background is not only used for shortcuts but for saved HTML documents as well.

In addition to being unexpected, the new dark icon is an eye sore and negatively contrasts with every other document icon that resides on my desktop. Firefox logo in itself makes associated document's identification easy; the dark background breaks visual coherence, distracts and goes against Windows traditions of having white/light background for document icons. 

If an icon with light background for shortcuts/documents cannot be returned, adding an alternative document icon with light background to the Firefox executable will allow people who care to change it manually.

Both official branding and nightly/Dev edition need the change.
(In reply to Gervase Markham [:gerv] from comment #6)
> shorlander: a black "page" does seem a slightly strange choice; can you shed
> more light on the reasoning here?
> 
> Gerv

As part of the icon design update we wanted to tie into our updated color palette and decided that placement on a dark background made the icon stand out more. See: Windows start menu tiles, document icons, mobile (iOS/Android) app container background.
Flags: needinfo?(shorlander)
(In reply to Stephen Horlander [:shorlander] from comment #8)
> (In reply to Gervase Markham [:gerv] from comment #6)
> > shorlander: a black "page" does seem a slightly strange choice; can you shed
> > more light on the reasoning here?
> > 
> > Gerv
> 
> As part of the icon design update we wanted to tie into our updated color
> palette and decided that placement on a dark background made the icon stand
> out more. See: Windows start menu tiles, document icons, mobile
> (iOS/Android) app container background.

Should we revisit this decision, given that 1) this isn't just some background but a sheet of paper, and 2) this is inconsistent with most if not all other document icons that users will encounter?
Flags: needinfo?(shorlander)
(In reply to Dão Gottwald [::dao] from comment #9)
> (In reply to Stephen Horlander [:shorlander] from comment #8)
> > (In reply to Gervase Markham [:gerv] from comment #6)
> > > shorlander: a black "page" does seem a slightly strange choice; can you shed
> > > more light on the reasoning here?
> > > 
> > > Gerv
> > 
> > As part of the icon design update we wanted to tie into our updated color
> > palette and decided that placement on a dark background made the icon stand
> > out more. See: Windows start menu tiles, document icons, mobile
> > (iOS/Android) app container background.
> 
> Should we revisit this decision, given that 1) this isn't just some
> background but a sheet of paper, and 2) this is inconsistent with most if
> not all other document icons that users will encounter?

I don't think so. There are no hard rules around what a document can look like. Adobe for instance uses dark background for file types. It doesn't sound like there is actual confusion around what it is, but instead a preference for how it looks.
Flags: needinfo?(shorlander)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Here is how it looks on my computer. The new document icon does stand out among the rest but not in a good way. It looks broken and jarring.

For me the dark background is closer associated with the Developers' Edition rather than the final product. Can an official alternate document icon with white or gray background be created for people who want to download and use it?
You need to log in before you can comment on or make changes to this bug.