Closed Bug 14180 Opened 20 years ago Closed 19 years ago

when no windows open, non-applicable menu items still active

Categories

(SeaMonkey :: UI Design, defect, P3)

PowerPC
Mac System 8.5
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 25287

People

(Reporter: mikepinkerton, Assigned: don)

Details

(Keywords: platform-parity)

-Start apprunner
-close all browser windows
-now you're left with a menubar full of things that aren't valid because there is
no current browser window, but you can still select them. At least it doesn't
crash. ;)

Either we want to disable all of these, or use a different menubar which doesn't
have 90% of this stuff in it, since all you can really do at this point is opena
new window, bookmarks, history, or prefs.
Assignee: don → davidm
reassign
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I think I disabled everything. The translate and Charset menu's are not disable
because of what I consider Toolkit bugs. I left anything that launched it's own
window in ( wallet, some of the find code).
QA Contact: beppe → cpratt
Status: RESOLVED → VERIFIED
I don't believe this is 100% fixed. For example, Find On This Page remains
active although that doesn't make any sense contextually. Some of the Wallet
stuff seems wrong too (eg Safe Form Fill). Reopening - please close if you meant
to do it this way. Thanks! 1999110916 build, Mac OS 9.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Target Milestone: M13
Even if this isn't completely fixed, I don't think we have to finish it by M12.
Assignee: davidm → don
Status: REOPENED → NEW
Target Milestone: M13 → M15
Move to M15.
You can't disable menu items if they're not there at all ... marking dependent on 
32067.
Depends on: 32067
QA Contact: cpratt → elig
QA Assigning to sarah.
QA Contact: elig → sairuh
Keywords: pp
The dependance on bug 32067 is sketchy. The existance of bug 32067 isn't static - 

it comes and goes between builds (it's either a problem on a certain build or 

it's not). I experienced 32067 on 3/18 but not on 3/19. I don't think the two 

bugs are completely related in terms of where they're breaking, either.

Yes, bug 32067 seems to be trunk only; so this bug can still be worked on on the 
beta branch. Removing dependency.
No longer depends on: 32067
Move to M16 for now ...
Target Milestone: M15 → M16
Target Milestone: M16 → M18
Move to M21 target milestone.
Target Milestone: M18 → M21
Should be the other way around but bug 25287 has more recent comments and a
valid target MS.

*** This bug has been marked as a duplicate of 25287 ***
Status: NEW → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.