Closed Bug 1418026 Opened 2 years ago Closed 2 years ago

Remove unused code from js/src/frontend

Categories

(Core :: JavaScript Engine, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: anba, Assigned: anba)

References

Details

Attachments

(1 file)

No description provided.
Attached patch bug1418026.patchSplinter Review
Removes some unused functions from js/src/frontend and additionally:

FullParseHandler.h
- Inlined lazyOuterFunction() getter to directly access the class field.

SyntaxParseHandler.h
- Inlined isUnparenthesizedName() into its sole caller isNameAnyParentheses().

telemetry/Histograms.json
- Added "(obsolete)" comment to all unused entries.
Attachment #8929118 - Flags: review?(jdemooij)
Blocks: 1418235
Comment on attachment 8929118 [details] [diff] [review]
bug1418026.patch

Review of attachment 8929118 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.

::: js/src/frontend/LanguageExtensions.h
@@ +28,2 @@
>      // NO LONGER USING 2
>      ExpressionClosure = 3, // Added in JS 1.8

Ah the last one - we've come a long way :)
Attachment #8929118 - Flags: review?(jdemooij) → review+
(In reply to Jan de Mooij [:jandem] from comment #2)
> ::: js/src/frontend/LanguageExtensions.h
> @@ +28,2 @@
> >      // NO LONGER USING 2
> >      ExpressionClosure = 3, // Added in JS 1.8
> 
> Ah the last one - we've come a long way :)

Yeah, totally! :-)
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/65629d4e9531
Remove unused code from js/src/frontend. r=jandem
Keywords: checkin-needed
Priority: -- → P2
https://hg.mozilla.org/mozilla-central/rev/65629d4e9531
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Duplicate of this bug: 1400089
You need to log in before you can comment on or make changes to this bug.