Iframe link opens in new window instead of new tab after LMB click

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
2 months ago
2 months ago

People

(Reporter: imr, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 months ago
Created attachment 8929194 [details]
Firefox-bug.PNG

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171112125346

Steps to reproduce:

1. Open webpage that has Videos/links nested in iframes (like reddit.com).
2. Expand a reddit entry to view small iframe with video window (youtube) - see attachment.
3. Click on Youtube logo within the player window inside iframe.


Actual results:

Youtube opens in new window.


Expected results:

Youtube should open in new tab.
(Reporter)

Comment 1

2 months ago
I think it might be connected with the relation between current protocol (https) and no protocol specified for the URL (http or starts with domain). Not sure tho.
Created attachment 8930413 [details]
Screen Shot 2017-11-21 at 12.16.53.png

Tested on Build ID 20171112125346 Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0b OS  Windows_NT 10.0 following the STR provided, and after numerous tries, could not reproduce the issue.

imr do you have the "Open new windows in a new tab instead" option box checked from Preferences>General>Tabs ? (screenshot attached) That might the problem. Thank you
Flags: needinfo?(imr)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

2 months ago
(In reply to Deac Alin from comment #2)
> Created attachment 8930413 [details]
> Screen Shot 2017-11-21 at 12.16.53.png
> 
> Tested on Build ID 20171112125346 Mozilla/5.0 (Windows NT 10.0; Win64; x64;
> rv:57.0) Gecko/20100101 Firefox/57.0b OS  Windows_NT 10.0 following the STR
> provided, and after numerous tries, could not reproduce the issue.
> 
> imr do you have the "Open new windows in a new tab instead" option box
> checked from Preferences>General>Tabs ? (screenshot attached) That might the
> problem. Thank you

I'm terribly sorry. You are right. Never had that setting before, but this time I must have enabled/disabled it by mistake.
Flags: needinfo?(imr)
You need to log in before you can comment on or make changes to this bug.