Closed Bug 1418126 Opened 2 years ago Closed 2 years ago

Dark Theme: bright gradient on the forward button on spiegel.de

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
All
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- fixed

People

(Reporter: darkspirit, Assigned: ethlin)

References

(Blocks 1 open bug, )

Details

(Keywords: nightly-community, Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(2 files)

Attached file testcase.html
Nightly 59 x64 20171116100106 de_DE f41930a869a84af81df1a88d8e82323ff3a6509a @ Debian Testing (KDE, Radeon RX480)
fresh profile: layers.acceleration.force-enabled, gfx.webrender.enabled, Dark Theme(!)

See attached testcase + video.

There is also something bright on the top left of an app tab when this testcase is open.
The testcase does not longer work if I remove one of those CSS properties.
It's only reproducible when spiegel.de informs me that I have an Adblocker.

This also happens when layout.display-list.retain (bug 1416055) is disabled.
Fixed by disabling WebRender.
about:addons > Themes > Black Theme
If you don't see it directly: Open the testcase, open another tab and switch back to the testcase.

mozregression --good 2017-10-15 --bad 2017-11-16 --pref "layers.acceleration.force-enabled:true" "gfx.webrender.enabled:true" "gfx.webrendest.enabled:true" "gfx.webrender.layers-free:true" "gfx.webrender.blob-images:true" --profile-persistence clone-first
(so many broken builds)
> 38:42.72 INFO: Last good revision: e97bbbe3841f70c4c8b53f85a56524245f2393d3
> 38:42.72 INFO: First bad revision: 2a8eb883a2792c876a03bd2053863d7639387fbe
> 38:42.72 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e97bbbe3841f70c4c8b53f85a56524245f2393d3&tochange=2a8eb883a2792c876a03bd2053863d7639387fbe

There are opacity and a blur filter in my testcase, so I suspect this one:
> bug title: "Investigate why facebook still use software rendering for blur filter."
> Morris Tseng — Bug 1411813 - Don't fallback nsDisplayFilter if opacity is present. r=kats
Has Regression Range: --- → yes
Has STR: --- → yes
Nightly 59 x64 20171116100106 de_DE f41930a869a84af81df1a88d8e82323ff3a6509a @ Windows 10 1709 (Radeon RX480)
fresh profile: gfx.webrender.enabled
If you don't see it directly: Open the testcase, open another tab, pin it as app tab, switch back to the testcase
OS: Linux → All
Could you please check the comment 2?
Flags: needinfo?(mtseng)
Whiteboard: [wr-mvp] [triage] → [wr-mvp] [triage] [gfx-noted]
Priority: -- → P3
Whiteboard: [wr-mvp] [triage] [gfx-noted] → [wr-mvp] [triage] [gfx-noted][wr-reserve-candidate]
Whiteboard: [wr-mvp] [triage] [gfx-noted][wr-reserve-candidate] → [wr-reserve] [gfx-noted]
This seems to be fixed.

1. Enable the Black Theme
2. open https://bugzilla.mozilla.org/attachment.cgi?id=8929221 and three other tabs. Pin all as app tab. The testcase should be the first app tab.
3. Now look whether the tab of the testcase has an ugly reload button

mozregression --find-fix --bad 2017-11-16 --good 2017-11-18 --pref "layers.acceleration.force-enabled:true" "gfx.webrender.enabled:true" "gfx.webrender.blob-images:true" --profile-persistence clone-first
(so many broken builds)
> 71:58.20 INFO: First good revision: ec69c7fcd213bde18fd4fc6850589bbe1e8dda87
> 71:58.20 INFO: Last bad revision: 249a8177ad915734b83c357d49213e26d889b377
> 71:58.20 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=249a8177ad915734b83c357d49213e26d889b377&tochange=ec69c7fcd213bde18fd4fc6850589bbe1e8dda87


bad: mozregression --repo autoland --launch 8d16bdf7d0fc --pref "layers.acceleration.force-enabled:true" "gfx.webrender.enabled:true" "gfx.webrender.blob-images:true"

bad: mozregression --repo autoland --launch ef9858e9ad38 --pref "layers.acceleration.force-enabled:true" "gfx.webrender.enabled:true" "gfx.webrender.blob-images:true"

first good build:
mozregression --repo autoland --launch c80c224d6b0c --pref "layers.acceleration.force-enabled:true" "gfx.webrender.enabled:true" "gfx.webrender.blob-images:true"
> c80c224d6b0c	Kartikaya Gupta — Bug 1417062 - Update webrender to commit d490a74c438d987122c600afca6bb2247ab38637. r=nical
> https://github.com/servo/webrender/compare/8a39cf24f493e894a66c2465dd310a2b2923e558...d490a74c438d987122c600afca6bb2247ab38637
(Who and what fixed it?)

good: mozregression --repo autoland --launch cdf4bb1c6af6 --pref "layers.acceleration.force-enabled:true" "gfx.webrender.enabled:true" "gfx.webrender.blob-images:true
Depends on: 1417062
I think maybe one of those commits fix the problem.

demo99 - Make sure we un-premultiply alpha before applying filters. 82cc7df 
glennw - Introduce PicturePrimitive::Image. 6ca43c3
Flags: needinfo?(mtseng)
(I mark this as WFM, although I expected you would mark this as fixed and assign this bug to someone.)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
Priority: P3 → --
Whiteboard: [wr-reserve] [gfx-noted] → [gfx-noted]
Priority: -- → P1
Whiteboard: [gfx-noted] → [wr-mvp] [gfx-noted]
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.