Closed Bug 1418156 Opened 2 years ago Closed 2 years ago

Make PrefHashEntry smarter

Categories

(Core :: Preferences: Backend, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: njn, Assigned: njn)

References

Details

Attachments

(10 files, 8 obsolete files)

59 bytes, text/x-review-board-request
glandium
: review+
Details
59 bytes, text/x-review-board-request
glandium
: review+
Details
59 bytes, text/x-review-board-request
glandium
: review+
Details
59 bytes, text/x-review-board-request
glandium
: review+
Details
59 bytes, text/x-review-board-request
glandium
: review+
Details
59 bytes, text/x-review-board-request
glandium
: review+
Details
59 bytes, text/x-review-board-request
glandium
: review+
Details
59 bytes, text/x-review-board-request
glandium
: review+
Details
59 bytes, text/x-review-board-request
glandium
: review+
Details
59 bytes, text/x-review-board-request
glandium
: review+
Details
PrefHashEntry is currently a very dumb class. I want to make it much smarter, by moving lots of functions into it. This will make various things nicer.
Attachment #8929264 - Attachment is obsolete: true
Attachment #8929264 - Flags: review?(mh+mozilla)
Attachment #8929265 - Attachment is obsolete: true
Attachment #8929265 - Flags: review?(mh+mozilla)
Attachment #8929266 - Attachment is obsolete: true
Attachment #8929266 - Flags: review?(mh+mozilla)
Attachment #8929267 - Attachment is obsolete: true
Attachment #8929267 - Flags: review?(mh+mozilla)
Attachment #8929268 - Attachment is obsolete: true
Attachment #8929268 - Flags: review?(mh+mozilla)
Attachment #8929269 - Attachment is obsolete: true
Attachment #8929269 - Flags: review?(mh+mozilla)
Attachment #8929270 - Attachment is obsolete: true
Attachment #8929270 - Flags: review?(mh+mozilla)
Attachment #8929271 - Attachment is obsolete: true
Attachment #8929271 - Flags: review?(mh+mozilla)
Comment on attachment 8929263 [details]
Bug 1418156 - Remove forward declaration of PrefHashEntry.

https://reviewboard.mozilla.org/r/200554/#review205720
Attachment #8929263 - Flags: review?(mh+mozilla) → review+
Comment on attachment 8929277 [details]
Bug 1418156 - Don't zero newly added PrefHashEntrys.

https://reviewboard.mozilla.org/r/200582/#review205724
Attachment #8929277 - Flags: review?(mh+mozilla) → review+
Comment on attachment 8929278 [details]
Bug 1418156 - Merge PrefTypeFlags into PrefHashEntry.

https://reviewboard.mozilla.org/r/200584/#review205726

::: modules/libpref/Preferences.cpp:178
(Diff revision 1)
> -  void SetHasUserValue(bool aSetOrUnset)
> -  {
> +  bool IsSticky() const { return mIsSticky; }
> +  void SetIsSticky(bool aValue) { mIsSticky = aValue; }
> -    SetFlag(PREF_FLAG_HAS_USER_VALUE, aSetOrUnset);
> -  }
>  
> -private:
> -  static uint16_t AsInt(PrefType aType) { return (uint16_t)aType; }
> +  bool IsLocked() const { return mIsLocked; }
> +  void SetLocked(bool aValue) { mIsLocked = aValue; }

The discrepancy between IsLocked/SetLocked and IsSticky/SetIsSticky is weird.
Attachment #8929278 - Flags: review?(mh+mozilla) → review+
Comment on attachment 8929279 [details]
Bug 1418156 - Move the PLDHashTable ops into PrefHashEntry.

https://reviewboard.mozilla.org/r/200586/#review205732
Attachment #8929279 - Flags: review?(mh+mozilla) → review+
Comment on attachment 8929280 [details]
Bug 1418156 - Overhaul GetPrefValueFromEntry.

https://reviewboard.mozilla.org/r/200588/#review205736
Attachment #8929280 - Flags: review?(mh+mozilla) → review+
Comment on attachment 8929281 [details]
Bug 1418156 - Move pref_GetPrefFromEntry into PrefHashEntry.

https://reviewboard.mozilla.org/r/200590/#review205750
Attachment #8929281 - Flags: review?(mh+mozilla) → review+
Comment on attachment 8929282 [details]
Bug 1418156 - Move pref_EntryHasAdvisablySizedValues() into PrefHashEntry.

https://reviewboard.mozilla.org/r/200592/#review205754
Attachment #8929282 - Flags: review?(mh+mozilla) → review+
Comment on attachment 8929283 [details]
Bug 1418156 - Rename PrefHashEntry::mKey as mName, and make it private.

https://reviewboard.mozilla.org/r/200594/#review205758
Attachment #8929283 - Flags: review?(mh+mozilla) → review+
Comment on attachment 8929284 [details]
Bug 1418156 - Move pref_SetValue() into PrefHashEntry.

https://reviewboard.mozilla.org/r/200596/#review205760
Attachment #8929284 - Flags: review?(mh+mozilla) → review+
Comment on attachment 8929272 [details]
Bug 1418156 - Remove unnecessary forward declaration of pref_SetPref().

https://reviewboard.mozilla.org/r/200572/#review205762
Attachment #8929272 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/02b07373f9f23770c8ccf6db456f8d6b1a75f3b2
Bug 1418156 - Remove forward declaration of PrefHashEntry. r=glandium

https://hg.mozilla.org/integration/mozilla-inbound/rev/6f4fd4cef48e8210489050bd482edfe491223c42
Bug 1418156 - Don't zero newly added PrefHashEntrys. r=glandium

https://hg.mozilla.org/integration/mozilla-inbound/rev/b109b4b29eb7e569c3a862db2f0ef35366596b3d
Bug 1418156 - Merge PrefTypeFlags into PrefHashEntry. r=glandium

https://hg.mozilla.org/integration/mozilla-inbound/rev/b16dfe143b271f9b8c7e20677615846842bf58a4
Bug 1418156 - Move the PLDHashTable ops into PrefHashEntry. r=glandium

https://hg.mozilla.org/integration/mozilla-inbound/rev/4bec38deb68bc09cedd3d99c5e1f8f7cb72a43e7
Bug 1418156 - Overhaul GetPrefValueFromEntry. r=glandium

https://hg.mozilla.org/integration/mozilla-inbound/rev/bcc25f198c1761c8eab5a68bb4905e86c6a572ad
Bug 1418156 - Move pref_GetPrefFromEntry into PrefHashEntry. r=glandium

https://hg.mozilla.org/integration/mozilla-inbound/rev/acfdad86187d760ade47a36528ba340c6c5d4ac1
Bug 1418156 - Move pref_EntryHasAdvisablySizedValues() into PrefHashEntry. r=glandium

https://hg.mozilla.org/integration/mozilla-inbound/rev/5ab1f93c8ec0556df05823699b0eb2cb95a93e07
Bug 1418156 - Rename PrefHashEntry::mKey as mName, and make it private. r=glandium

https://hg.mozilla.org/integration/mozilla-inbound/rev/a2c5f2b65d56a05c9a618fe504e6d5cff59b1beb
Bug 1418156 - Move pref_SetValue() into PrefHashEntry. r=glandium

https://hg.mozilla.org/integration/mozilla-inbound/rev/98646e193600531078091d7da9a64df32e008661
Bug 1418156 - Remove unnecessary forward declaration of pref_SetPref(). r=glandium
Duplicate of this bug: 1251366
You need to log in before you can comment on or make changes to this bug.