hg.mozilla.org account for jthemphill@gmail.com

RESOLVED INVALID

Status

mozilla.org
Repository Account Requests
RESOLVED INVALID
2 months ago
2 months ago

People

(Reporter: jthemphill, Assigned: marcia)

Tracking

Details

(Reporter)

Description

2 months ago
I can push to MozReview and schedule try jobs from there, but I can't push directly to try.

```
./mach try empty
216d112216f8 -> 100234702948 "Bug 1417827: Convert internal char* to nsCStrin..."
Creating temporary commit for remote...
A try_task_config.json
pushing to ssh://hg.mozilla.org/try
remote: Permission denied (publickey).
temporary commit removed, repository restored
abort: no suitable response from remote hg!
```

After looking at https://developer.mozilla.org/en-US/docs/Mercurial/Using_Mercurial#How_do_I_check_stuff_in.3F, I believe this is because I don't have an hg.mozilla.org account.

```
ssh hg.mozilla.org
Permission denied (publickey)
```

I already have level 1 commit access (Bug 1412594).

Comment 1

2 months ago
Does `ssh jthemphill@gmail.com@hg.mozilla.org` work? If so, you need to set up your ssh config file like the wiki page describes.

Updated

2 months ago
Flags: needinfo?(jthemphill)
(Reporter)

Comment 2

2 months ago
It didn't work, but then I ran `ssh-add -l` and found that my SSH agent forgot about my public key. I've got something misconfigured; all the problems are on my end.

Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Flags: needinfo?(jthemphill)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.