Recent nightly builds are partly untranslated

VERIFIED FIXED in Firefox 58

Status

()

defect
P3
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: piotrdrag, Assigned: m_kato)

Tracking

Firefox 59
Firefox 59
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec+, firefox57 unaffected, firefox58 verified, firefox59 verified)

Details

Attachments

(3 attachments)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171113102334

Steps to reproduce:

Recent nightlies (last week or two) are partly in English, instead of being completely in Polish. These strings are translated, so this is not a translation issue.
tracking-fennec: --- → ?
Component: General → Locale switching and selection
OS: Unspecified → Android
Hardware: Unspecified → ARM
Thanks for report!

I was not able to reproduce this issue using latest nightly build and HTC 8 (Android 7.0). I installed Polish build and the string was translated, and also, I change the language from settings, and again the strings was translated. 

On what device did you find the issue?
The device language are you using?
Flags: needinfo?(piotrdrag)
I’m using Moto E 2nd Gen (Android 6.0). The device is set to Polish. I tried removing the app data, as well as reinstalling it.
Flags: needinfo?(piotrdrag)
Flags: needinfo?(gandalf)
Does the partial translation persist accross restarts?
Flags: needinfo?(gandalf) → needinfo?(piotrdrag)
Both force quitting the app and restarting the device make no difference.
Flags: needinfo?(piotrdrag)
Can you open "about:support" and copy&paste here the l10n/intl section?
(In reply to Sorina Florean [:sorina] from comment #3)
> I was not able to reproduce this issue using latest nightly build and HTC 8
> (Android 7.0). I installed Polish build and the string was translated, and
> also, I change the language from settings, and again the strings was
> translated. 

From the similar bug 1419822, the issue could only happen if Firefox language is set to "system default" (with "system default" being something else than English). Complete steps to reproduce are in this bug 1419822.

All the identified items that are presented in English are:
 - "tip" at the bottom of Firefox start page
 - about:pages (at least about:firefox, about:config, about:cache, about:mozilla)
 - link or image popup menu - screenshot: https://framapic.org/sH54Ys32BiwP/l3wez7kFj1Qo.png
 - selected text "copy/paste/etc." popup.

Firefox 57.0 is not affected. Firefox 58.0b3, 58.0b5 and 59.0a1 (2017-11-22) are affected.
(In reply to Nicolas Turcot (:nico@nc) from comment #8)
> From the similar bug 1419822, the issue could only happen if Firefox
> language is set to "system default" (with "system default" being something
> else than English). Complete steps to reproduce are in this bug 1419822.
> 

Yep, it’s the same issue.
Duplicate of this bug: 1419822
(In reply to Piotr Drąg [:piotrdrag] from comment #10)
> (In reply to Nicolas Turcot (:nico@nc) from comment #8)
> > From the similar bug 1419822, the issue could only happen if Firefox
> > language is set to "system default" (with "system default" being something
> > else than English). Complete steps to reproduce are in this bug 1419822.
> > 
> 
> Yep, it’s the same issue.

Ok, I marked my bug as a duplicate of this one then.

(In reply to Piotr Drąg [:piotrdrag] from comment #9)
> Created attachment 8931083 [details]
> l10n/intl section of about:support

I have the exact same thing in about:support. No mention of the "fr" locale, although most of Firefox interface is in French.
Ok, I'll investigate it. We didn't change anything around it recently except of bug 8931083, but the presence of intl.properties in the list indicates some kind of error.

Thank you for reporting!
Flags: needinfo?(gandalf)
:m_kato has a fix in bug 1420332 that, according to my testing, fixes this bug.
Status: UNCONFIRMED → NEW
Depends on: 1420332
Ever confirmed: true
Flags: needinfo?(gandalf)
Could you please verify again on tomorrow's Nightly?
tracking-fennec: ? → +
Flags: needinfo?(piotrdrag)
Priority: -- → P3
Nov 30 build is fully in Polish again.

Thank you, everyone!
Flags: needinfo?(piotrdrag)
great, thank you!
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Assignee: nobody → m_kato
Target Milestone: --- → Firefox 59
I was able to reproduce this bug after setting the device language to Polish. Tested again following the steps from bug 1419822 on latest Nightly build( 12/13) and latest Beta (58.0b11) and the issue is fixed.
Device: HTC 10 (Android 7.0).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.