suite/profile/nsSuiteDirectoryProvider.cpp: error: 'NS_APP_SEARCH_DIR_LIST' was not declared in this scope

RESOLVED FIXED in Seamonkey2.56

Status

SeaMonkey
Build Config
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

unspecified
Seamonkey2.56

SeaMonkey Tracking Flags

(seamonkey2.54 fixed, seamonkey2.55 fixed, seamonkey2.56 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 months ago
/builds/slave/c-cen-t-lnx/build/objdir/_virtualenv/bin/python /builds/slave/c-cen-t-lnx/build/mozilla/config/expandlibs_gen.py -o libdom_ipc.a.desc ContentChild.o ProcessHangMonitor.o Unified_cpp_dom_ipc0.o Unified_cpp_dom_ipc1.o 
make[4]: Leaving directory `/builds/slave/c-cen-t-lnx/build/objdir/dom/ipc'
make[4]: Entering directory `/builds/slave/c-cen-t-lnx/build/objdir/suite/profile/migration/src'
mkdir -p '.deps/'
/usr/bin/ccache /builds/slave/c-cen-t-lnx/build/gcc/bin/g++ -m32 -march=pentium-m -std=gnu++14 -o nsNetscapeProfileMigratorBase.o -c -I/builds/slave/c-cen-t-lnx/build/objdir/dist/stl_wrappers -I/builds/slave/c-cen-t-lnx/build/objdir/dist/system_wrappers -include /builds/slave/c-cen-t-lnx/build/mozilla/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/builds/slave/c-cen-t-lnx/build/suite/profile/migration/src -I/builds/slave/c-cen-t-lnx/build/objdir/suite/profile/migration/src -I/builds/slave/c-cen-t-lnx/build/objdir/dist/include -I/builds/slave/c-cen-t-lnx/build/objdir/dist/include/nspr -I/builds/slave/c-cen-t-lnx/build/objdir/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/slave/c-cen-t-lnx/build/objdir/mozilla-config.h -D_FORTIFY_SOURCE=2 -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=free-nonheap-object -Wformat -msse -msse2 -mfpmath=sse -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -D_GLIBCXX_USE_CXX11_ABI=0 -pipe -g -freorder-blocks -O2 -fno-omit-frame-pointer -Werror  -MD -MP -MF .deps/nsNetscapeProfileMigratorBase.o.pp   /builds/slave/c-cen-t-lnx/build/suite/profile/migration/src/nsNetscapeProfileMigratorBase.cpp
/builds/slave/c-cen-t-lnx/build/gcc/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.9.4/../../../../x86_64-unknown-linux-gnu/bin/as: /lib64/libz.so.1: no version information available (required by /builds/slave/c-cen-t-lnx/build/gcc/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.9.4/../../../../x86_64-unknown-linux-gnu/bin/as)
../../../suite/profile/nsSuiteDirectoryProvider.cpp: In member function 'virtual nsresult nsSuiteDirectoryProvider::GetFiles(const char*, nsISimpleEnumerator**)':
../../../suite/profile/nsSuiteDirectoryProvider.cpp:66:20: error: 'NS_APP_SEARCH_DIR_LIST' was not declared in this scope
   if (strcmp(aKey, NS_APP_SEARCH_DIR_LIST))
                    ^
make[4]: *** [nsSuiteDirectoryProvider.o] Error 1
make[4]: Leaving directory `/builds/slave/c-cen-t-lnx/build/objdir/suite/profile'
make[3]: *** [suite/profile/target] Error 2
make[3]: *** Waiting for unfinished jobs....
(Assignee)

Comment 1

2 months ago
IanN,  bug 1405670 busted us..  They've removed NS_APP_SEARCH_DIR_LIST and instead
of willy-nilly removing this from our code,  do we still use it?
Flags: needinfo?(iann_bugzilla)
(Assignee)

Comment 2

2 months ago
Created attachment 8929673 [details] [diff] [review]
proposed patch
Attachment #8929673 - Flags: review?(iann_bugzilla)

Updated

2 months ago
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Flags: needinfo?(iann_bugzilla)

Comment 3

2 months ago
Comment on attachment 8929673 [details] [diff] [review]
proposed patch

NS_APP_USER_SEARCH_DIR was also removed so the sections relating that need removing as does AppendFileKey
You might as well adopt the same code that is used by TB/Fx:
 NS_IMETHODIMP
 DirectoryProvider::GetFiles(const char *aKey, nsISimpleEnumerator* *aResult)
 {
   if (!strcmp(aKey, NS_APP_DISTRIBUTION_SEARCH_DIR_LIST)) {
     nsCOMPtr<nsIProperties> dirSvc
       (do_GetService(NS_DIRECTORY_SERVICE_CONTRACTID));
     if (!dirSvc)
       return NS_ERROR_FAILURE;
 
     nsCOMArray<nsIFile> distroFiles;
     AppendDistroSearchDirs(dirSvc, distroFiles);
 
     return NS_NewArrayEnumerator(aResult, distroFiles);
   }
   return NS_ERROR_FAILURE;
 }
Attachment #8929673 - Flags: review?(iann_bugzilla) → review-
(Assignee)

Comment 4

2 months ago
Created attachment 8929950 [details] [diff] [review]
proposed patch (v2)
Attachment #8929673 - Attachment is obsolete: true
Attachment #8929950 - Flags: review?(iann_bugzilla)
Comment on attachment 8929950 [details] [diff] [review]
proposed patch (v2)

Stealing review. LGTM.

Just for reference: 

NS_APP_USER_SEARCH_DIR is still defined in mozilla/xpcom/io/nsAppDirectoryServiceDefs.h but no longer does anything. Should be removed there too soon.
Attachment #8929950 - Flags: review?(iann_bugzilla) → review+

Comment 6

2 months ago
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/976cd8d722ff
Port [Bug 1405670 - Stop importing old search settings from search-metadata.json] to SeaMonkey. r=frg
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
status-seamonkey2.56: --- → fixed
Target Milestone: --- → Future
Target Milestone: Future → Seamonkey2.56
Comment on attachment 8929950 [details] [diff] [review]
proposed patch (v2)

This has been uplifted 11/29. Compile now fails.

[Approval Request Comment]
Regression caused by (bug #): 1405670
User impact if declined: no SeaMonkey
Testing completed (on m-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): none already broken.
String changes made by this patch: --
Attachment #8929950 - Flags: approval-comm-release?
Attachment #8929950 - Flags: approval-comm-beta?
I stand corrected
beta uplift was done 11/27
release uplift was done 11/22
status-seamonkey2.54: --- → affected
status-seamonkey2.55: --- → affected

Comment 9

2 months ago
Comment on attachment 8929950 [details] [diff] [review]
proposed patch (v2)

a=me
Attachment #8929950 - Flags: approval-comm-release?
Attachment #8929950 - Flags: approval-comm-release+
Attachment #8929950 - Flags: approval-comm-beta?
Attachment #8929950 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.