Closed Bug 1418566 Opened 3 years ago Closed 3 years ago

Turn on MOZ_ALLOW_LEGACY_EXTENSIONS even in local builds

Categories

(Thunderbird :: Build Config, enhancement, P3)

enhancement

Tracking

(thunderbird58 fixed, thunderbird59 fixed)

RESOLVED FIXED
Thunderbird 59.0
Tracking Status
thunderbird58 --- fixed
thunderbird59 --- fixed

People

(Reporter: tomprince, Assigned: tomprince)

References

Details

Attachments

(1 file)

This was originally turned on in confvars.sh in Bug 1389195, but the configuration was moved to moz.configure in Bug 1363897. We turned it back on in Bug 1402471 but that only affect builds in CI.
++ i.e. great idea
Attachment #8929690 - Flags: approval-comm-beta?
Priority: -- → P3
Target Milestone: --- → Thunderbird 58.0
Comment on attachment 8929690 [details]
Bug 1418566: Turn on MOZ_ALLOW_LEGACY_EXTENSIONS even in local builds.

https://reviewboard.mozilla.org/r/200978/#review206182
Attachment #8929690 - Flags: review?(philipp) → review+
Comment on attachment 8929690 [details]
Bug 1418566: Turn on MOZ_ALLOW_LEGACY_EXTENSIONS even in local builds.

That's TB 58 beta.
Attachment #8929690 - Flags: approval-comm-beta? → approval-comm-beta+
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/comm-central/rev/8f7f2170dd25
Turn on MOZ_ALLOW_LEGACY_EXTENSIONS even in local builds; r=Fallen
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
If we do another 57b, we should land this there too.
I can't see myself doing a beta branch since on beta we're already at TB 58. What's the benefit for the user?
We've had a number of users that build thunderbird themselves complain that extensions don't work (which is caused by the lack of this configuration). I definitely don't think we should build another 57b for this fix, but if we are doing one for some other reason, then we should also include this fix as well.
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/comm-central/rev/3ef16c10c623
Remove unused MOZ_ALLOW_LEGACY_EXTENSIONS setting in linux64 debug mozconfig; r=me
Target Milestone: Thunderbird 58.0 → Thunderbird 59.0
You need to log in before you can comment on or make changes to this bug.