Closed Bug 1418666 Opened 4 years ago Closed 4 years ago

Not rendering comma in text

Categories

(Thunderbird :: Message Reader UI, defect)

defect
Not set
normal

Tracking

(thunderbird58 fixed, thunderbird59 fixed)

RESOLVED FIXED
Thunderbird 59.0
Tracking Status
thunderbird58 --- fixed
thunderbird59 --- fixed

People

(Reporter: staneck, Assigned: alta88)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171118100420

Steps to reproduce:

Nothing


Actual results:

Thunderbird does not render commas in text and message titles


Expected results:

It should render them
Attached image screenshot
So attachment 8929768 [details] shows the webpage http://stadt-bremerhaven.de/amazon-fire-7-ab-3999-euro-verfuegbar/ with commas and they got lost in the feed display? What's the feed URL?

Maybe caused by some over-zealous replacement her:
https://hg.mozilla.org/comm-central/rev/0b656c52b5465d8de6bc3bd42a66d3d26cf056cb
Flags: needinfo?(alta88)
The feed url is http://stadt-bremerhaven.de/feed and I checked that they show there.
Yep, the regexp matches the comma and removes it :-(
Attached patch regex.patchSplinter Review
uff. well, nice that someone's using nightly to test feeds, thanks.
Assignee: nobody → alta88
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #8929863 - Flags: review?(mkmelin+mozilla)
Flags: needinfo?(alta88)
You're welcome :)
Comment on attachment 8929863 [details] [diff] [review]
regex.patch

Thanks, I'll get this landed.
Attachment #8929863 - Flags: review?(mkmelin+mozilla) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/166a99245799
Bug 1411699 follow-up: Fix regex typo causing commas to be missing from feed content. r=jorgk DONTBUILD
Status: NEW → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 59.0
Attachment #8929863 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.