Closed Bug 1418710 Opened 2 years ago Closed Last year

Intermittent toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_basic.html | expected error message received in onErrorOccurred - Expected: NS_ERROR_UNKNOWN_HOST, Actual: NS_ERROR_NET_ON_RESOLVED

Categories

(WebExtensions :: General, defect, P5)

defect

Tracking

(firefox-esr60 fixed, firefox65 fixed, firefox66 fixed)

RESOLVED FIXED
mozilla66
Tracking Status
firefox-esr60 --- fixed
firefox65 --- fixed
firefox66 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: robwu)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed])

Attachments

(1 file)

Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=145847785&repo=mozilla-central

https://queue.taskcluster.net/v1/task/Jn_aTLxnTeat_I7XpYNMtQ/runs/0/artifacts/public/logs/live_backing.log

21:06:08     INFO -  2035 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_basic.html | origin is correct - Expected: http://mochi.test:8888/tests/toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_basic.html, Actual: http://mochi.test:8888/tests/toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_basic.html
21:06:08     INFO -  2036 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_basic.html | correct requestId - Expected: 41, Actual: 41
21:06:08     INFO -  2037 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_basic.html | correct tabId - Expected: 2, Actual: 2
21:06:08     INFO -  Buffered messages finished
21:06:08    ERROR -  2038 INFO TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_basic.html | expected error message received in onErrorOccurred - Expected: NS_ERROR_UNKNOWN_HOST, Actual: NS_ERROR_NET_ON_RESOLVED
21:06:08     INFO -      onErrorOccurred@moz-extension://baea9339-7f4b-413a-aaa0-6dbdbe9c5e9d/%7B55c103bf-f9f5-4e5f-a83e-fa9e08b33989%7D.js:222:9
21:06:08     INFO -      getListener/<@moz-extension://baea9339-7f4b-413a-aaa0-6dbdbe9c5e9d/%7B55c103bf-f9f5-4e5f-a83e-fa9e08b33989%7D.js:256:9
21:06:08     INFO -  2039 INFO onErrorOccurred 41 https://invalid.localhost/badrobot
21:06:08     INFO -  Not taking screenshot here: see the one that was previously logged
Duplicate of this bug: 1418716
Duplicate of this bug: 1419928
Product: Toolkit → WebExtensions
There are 37 failures in the last 7 days.
They occur on windows7-32 (debug, opt, pgo), osx-10-10 (debug, opt), linux64 (pgo, debug, opt), linux64-qr (debug, opt), linux64-nightly (opt), macosx64-nightly (opt), android-em-4-3-armv7-api16 (opt).
Recent failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=210527545&repo=autoland&lineNumber=31324
ddurst: Hi, can you have a look at this? Thanks!
Flags: needinfo?(ddurst)
Whiteboard: [stockwell needswork:owner]
This bug failed 33 times in the last 7 days. They occur on pretty much all platforms.

Log:
https://treeherder.mozilla.org/logviewer.html#?job_id=211819510&repo=autoland&lineNumber=31151

ddurst: Have you had a chance to take a look at this bug?
There are 40 failures in the last 7 days. David is someone working on this?
Flags: needinfo?(ddurst)
Flags: needinfo?(ddurst)
There are 37 failures for this bug in the last 7 days.

The most frequent on osx-10-10 and android-em-4-3-armv7-api16 platforms.

Recent log file: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=217273466&repo=autoland&lineNumber=28901

Log snippet: 
03:02:10     INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_webrequest_basic.html | correct requestId - Expected: 588, Actual: 588 
03:02:10     INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_webrequest_basic.html | correct tabId - Expected: 1, Actual: 1 
03:02:10     INFO - Buffered messages finished
03:02:10     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test_ext_webrequest_basic.html | expected error message received in onErrorOccurred - Expected: NS_ERROR_UNKNOWN_HOST, Actual: NS_ERROR_NET_ON_RESOLVED 
03:02:10     INFO -     SimpleTest.ok@SimpleTest/SimpleTest.js:275:7
03:02:10     INFO -     testHandler@SimpleTest/ExtensionTestUtils.js:59:7
03:02:10     INFO -     testResult@SimpleTest/ExtensionTestUtils.js:73:7
03:02:10     INFO -     Async*ExtensionTestUtils.loadExtension@SimpleTest/ExtensionTestUtils.js:105:19
03:02:10     INFO -     makeExtension@toolkit/components/extensions/test/mochitest/head_webrequest.js:314:10
03:02:10     INFO -     setup@toolkit/components/extensions/test/mochitest/test_ext_webrequest_basic.html:46:15
03:02:10     INFO -     async*nextTick/<@SimpleTest/AddTask.js:70:34
03:02:10     INFO -     async*nextTick@SimpleTest/AddTask.js:44:10
03:02:10     INFO -     setTimeout handler*SimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:684:12
03:02:10     INFO -     nextTick@SimpleTest/AddTask.js:40:11
03:02:10     INFO -     setTimeout handler*SimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:684:12
03:02:10     INFO -     add_task@SimpleTest/AddTask.js:30:7
03:02:10     INFO -     @toolkit/components/extensions/test/mochitest/test_ext_webrequest_basic.html:32:1
03:02:10     INFO - onErrorOccurred 588 https://invalid.localhost/badrobot
03:02:10     INFO - Not taking screenshot here: see the one that was previously logged
03:02:10     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test_ext_webrequest_basic.html | received onErrorOccurred 
03:02:10     INFO -     SimpleTest.ok@SimpleTest/SimpleTest.js:275:7
03:02:10     INFO -     testHandler@SimpleTest/ExtensionTestUtils.js:63:7
03:02:10     INFO -     testResult@SimpleTest/ExtensionTestUtils.js:73:7
03:02:10     INFO -     Async*ExtensionTestUtils.loadExtension@SimpleTest/ExtensionTestUtils.js:105:19
03:02:10     INFO -     makeExtension@toolkit/components/extensions/test/mochitest/head_webrequest.js:314:10
03:02:10     INFO -     setup@toolkit/components/extensions/test/mochitest/test_ext_webrequest_basic.html:46:15
03:02:10     INFO -     async*nextTick/<@SimpleTest/AddTask.js:70:34
03:02:10     INFO -     async*nextTick@SimpleTest/AddTask.js:44:10
03:02:10     INFO -     setTimeout handler*SimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:684:12
03:02:10     INFO -     nextTick@SimpleTest/AddTask.js:40:11
03:02:10     INFO -     setTimeout handler*SimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:684:12
03:02:10     INFO -     add_task@SimpleTest/AddTask.js:30:7
03:02:10     INFO -     @toolkit/components/extensions/test/mochitest/test_ext_webrequest_basic.html:32:1

ddurst: Hi, can you have a look at this? Thank you.
Whiteboard: [stockwell unknown] → [stockwell needswork:owner]
I saw a similar failure locally (NS_ERROR_CONNECTION_REFUSED on Linux), and can consistently reproduce it.

The domain in the test case is "invalid.localhost". It is conceivable that this domain is resolved because it ends with ".localhost". I also tried "not.localhost" and just "localhost", with the same effect. When I start a server at localhost, then I see that the test attempts to connect to this server.

The intent of the test is to have a non-resolvable domain, so I'll change the domain to a RFC2606-compliant non-resolvable domain.
Assignee: nobody → rob
Flags: needinfo?(ddurst)
Rob can we land this?
Flags: needinfo?(rob)
Yes. I've just sent it off to Lando.
Flags: needinfo?(rob)
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/1fd1e34371da
Use non-resolvable host in test_ext_webrequest_basic r=mixedpuppy
https://hg.mozilla.org/mozilla-central/rev/1fd1e34371da
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Whiteboard: [stockwell needswork:owner] → [stockwell fixed]
You need to log in before you can comment on or make changes to this bug.