regression: White discoloration on tabs behind text

RESOLVED DUPLICATE of bug 1424673

Status

()

defect
P1
normal
RESOLVED DUPLICATE of bug 1424673
2 years ago
a year ago

People

(Reporter: yoasif, Assigned: aosmond)

Tracking

(Blocks 1 bug, {nightly-community, regression})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox57 unaffected, firefox58 unaffected, firefox59 unaffected)

Details

(Whiteboard: [wr-reserve])

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171118100420

Steps to reproduce:

In about:config:
– set “gfx.webrender.enabled” to true,
– set “gfx.webrender.blob-images” to true,
– if you are on Linux, set “layers.acceleration.force-enabled” to true.

I have the "Safari Color Gradation" theme installed: https://addons.mozilla.org/en-US/firefox/addon/safari-color-gradation/ and am using an existing session. 


Actual results:

White discoloration on tabs behind text. See screenshot. 


Expected results:

As before it regressed.
(Reporter)

Comment 1

2 years ago
 8:53.40 INFO: Narrowed inbound regression window from [ef9858e9, df95c863] (3 builds) to [ef9858e9, cdf4bb1c] (2 builds) (~1 steps left)
 8:53.40 INFO: No more inbound revisions, bisection finished.
 8:53.40 INFO: Last good revision: ef9858e9ad38718eea180a62bb5b65561ad57d91
 8:53.40 INFO: First bad revision: cdf4bb1c6af6e53643d2beb0f10a2ce29207ff5e
 8:53.40 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ef9858e9ad38718eea180a62bb5b65561ad57d91&tochange=cdf4bb1c6af6e53643d2beb0f10a2ce29207ff5e
(Reporter)

Updated

2 years ago
Component: General → Graphics: WebRender
Nightly 59 x64 20171118100420 de_DE d4753dc14b2ab9c42123b6d60a68106df40f45cd @ Debian Testing (KDE, Radeon RX480)
fresh profile: layers.acceleration.force-enabled, gfx.webrender.enabled, gfx.webrender.blob-images

I can reproduce this. Especially behind and around "about:config" it almost looks like white. Fixed by disabling WebRender.

----------------

1. run mozregression
2. install https://addons.mozilla.org/en-US/firefox/addon/safari-color-gradation/
3. open about:config, switch to another tab, hover the about:config tab

(Reused commands from bug 1418126 comment 5)
good (last commit before the webrender update):
mozregression --repo autoland --launch ef9858e9ad38 --pref "layers.acceleration.force-enabled:true" "gfx.webrender.enabled:true" "gfx.webrender.blob-images:true"

bad (webrender update):
mozregression --repo autoland --launch c80c224d6b0c --pref "layers.acceleration.force-enabled:true" "gfx.webrender.enabled:true" "gfx.webrender.blob-images:true"
Blocks: 1417062
Has Regression Range: --- → yes
Has STR: --- → yes
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Summary: White discoloration on tabs behind text → regression: White discoloration on tabs behind text
Whiteboard: [wr-mvp] [triage]
Priority: -- → P3
Whiteboard: [wr-mvp] [triage] → [wr-mvp] [triage][wr-reserve-candidate]
Whiteboard: [wr-mvp] [triage][wr-reserve-candidate] → [wr-reserve]
(20171123100420) Probably the same issue. Usually it only happens after some time.
Theme: https://twitter.com/FirefoxNightly/status/933717466513072128
(Reporter)

Comment 4

2 years ago
@Jan, I tried out that theme and thought it looked great except for the text; didn't even think about trying it on a non WR profile. Glad to know it's a bug.
Duplicate of this bug: 1420912
This seems very visible to first-time WebRender testers -- shouldn't that make it [wr-mvp] (and > P3)?
Duplicate of this bug: 1418972
Duplicate of this bug: 1421632
OS: Linux → All
Hardware: x86_64 → All

Comment 9

2 years ago
This discoloration isn't always white, if engine thinks letter color is white enough, it will create black discoloration instead. (ex: https://addons.mozilla.org/en-US/firefox/addon/firefox-quantum-nightly/  )
I'm not able to reproduce this bug on OS X either using rev cdf4bb1c6af6e53643d2beb0f10a2ce29207ff5e ("first bad revision") or the current nightly. Might not affect OS X, or maybe it's intermittent, or maybe I'm just not seeing it. In the screenshot in comment 0 I can't see anything wrong; the screenshot in comment 2 shows some discoloration which is what I'm looking for and not finding when I try to repro.
Flags: needinfo?(jan)
I can still reproduce this. You need to use a light weight theme.
Ah, I see it in Nightly using either the "A Web Browser Renaissance" theme or the recommended "Pastel Gradient" theme. Doesn't show up with other themes as far as I can tell. I'll try to bisect into bug 1417062.
WR regression range is:

* 54e79688 Auto merge of #2031 - glennw:pic28, r=kvark
* fadae648 Address review comments and fix Gecko test failures.
* 0633bb37 Hide StackingContext
* 6ca43c34 Introduce PicturePrimitive::Image.

I filed servo/webrender#2176 for it.
Flags: needinfo?(jan)
Assignee: nobody → aosmond
Duplicate of this bug: 1429100
(Assignee)

Comment 15

a year ago
This is working in nightly, and after running mozregression + the Quantum Nightly theme, I found it was fixed by bug 1424673.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1424673
(Reporter)

Comment 16

a year ago
@Andrew, does that mean that the servo/webrender#2176 ticket should be closed as well? I can't do this, but figured I would ask.
You need to log in before you can comment on or make changes to this bug.