Closed Bug 1418723 Opened 2 years ago Closed 2 years ago

'Options' Buttons missing in Add-ons Manager

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: tawn, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171118100420

Steps to reproduce:

Open the Add-ons Manager
Look for 'Options' button for an extension.


Actual results:

Many extensions that have options show no 'Options' button. None of my legacy extensions (pref'd on) show Option button. Bootstrapped ext's inline options don't appear on the details page either. Happens even in clean profile. Not sure if applies to any webextensions (some of them do show Options button; some either missing button or perhaps they discontinued options when ported to webext).


Expected results:

Options button should be there. Is this bug or intended behavior?
For example my own https://addons.mozilla.org/firefox/addon/addons-manager-hilite/ (bootstrapped, inline options) exhibits this missing button, but happens on lots of other add-ons too.
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
Inline options support for bootstrapped extension is gone from Firefox Nightly.
I assume by "Options" you mean "Preferences", I see that button for my webextensions that actually have an options_ui in the manifest.  If you have a webextension that uses options_ui but the Preferences button doesn't show up, please re-open and include a link to the extension.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.