Bugzilla mail is delayed and arrives out of order

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: myk, Assigned: myk)

Tracking

Details

(Assignee)

Description

16 years ago
sendmail was reconfigured a few weeks ago to send mail from its queue every 15
minutes instead of every minute.  We did this to reduce load on the machine, but
the result is that Bugzilla mail is arriving late and out of order.  sendmail
should be reconfigured to send mail more quickly.
(Assignee)

Comment 1

16 years ago
Taking this one.
Assignee: endico → myk
QA Contact: myk → endico
So far, seems to be working much better.  Bugmail is mostly getting received
within 5 minutes now, or so it appears.  Some of them are even showing them
arriving at the destination server 2 or 3 minutes before being received from
Bugzilla by mothra.  :-)   (I think mothra's clock is off a little)
(Assignee)

Comment 3

16 years ago
I changed the queue interval from 15 minutes to 5 minutes last night, and I
guess it worked, but I'm going to leave this bug open until I get more feedback
that this definitively fixes the problem.
As of a few days ago, it takes 5-10 seconds for mail to be sent, and bzbot to
process it. In some cases, such as when I marka  bug as a dupe of one with lots
of people on the cc list, it announces the status change before the page has
finished loading for me.

I don't know what you did, but I'd say that 8 seconds for mail delivery is an
acceptable response time....
(Assignee)

Comment 5

16 years ago
Everyone says it works now, and that's because the "sendmailnow" parameter was
turned on last week or the week before (but I don't know by who).  It seems to
have done the trick without any negative side-effects, so I'll leave it on and
resolve this bug fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.