Closed Bug 1418792 Opened 5 years ago Closed 2 years ago

Cannot move window with touch in GNOME

Categories

(Core :: Widget: Gtk, defect, P5)

Unspecified
Linux
defect

Tracking

()

RESOLVED FIXED
90 Branch
Tracking Status
firefox90 --- fixed

People

(Reporter: 5i13ghzt462u, Assigned: jhorak, NeedInfo)

References

(Blocks 1 open bug)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171113102334

Steps to reproduce:

1. Open Firefox.
2. Try to move the window at the title bar via touch.

(tested with and without widget.allow-client-side-decoration)

GNOME v3.26, Fedora 27, Wayland


Actual results:

It does not move. I cannot "grab" it like that. In other GNOME application it works.

It works with the mouse.


Expected results:

The window should be movable by touch.

Likely related to Bug 1418611, which is about the "about window" and closing it, however. Closing the Firefox main window via touch, works.
Component: Untriaged → General
OS: Unspecified → Linux
Ah just could find out the issue: I am using Wayland, but as Firefox does not support Wayland yet, I tried the NightlyWayland build (flatpak) and it does indeed solve this issue.
Blocks: wayland
Version: 57 Branch → unspecified
Product: Firefox → Core
Component: General → Graphics
Okay, just tried it again with latest nightly and potentially discovered a different or similar issue.

And yes, it does work, but only when drawInTitlebar is disabled. When I allow drawing, it cannot be moved anymore.

60.0a1, otherwise same system
Priority: -- → P5
Whiteboard: [gfx-noted]
(In reply to rugk from comment #3)
> 60.0a1, otherwise same system

60.0a1 has Wayland-Spport built in. No XWayland is used if wayland is detected on start
Component: Graphics → Widget: Gtk

I can confirm, that with FF 66 on Fedora 29, this bugs still happens. (Related Bug 1418611 has been fixed in the meantime, i.e. I can move the about window, but I cannot move the main window via touch.)

I can totally minimize/maximize/close the window, but I cannot move it via touch.

And in contrast to what has been said before, I never saw this issue with other apps.
And as I think also Firefox uses Wayland by default now, the fault cannot be XWayland…

BTW, also reported downstream now: https://bugzilla.redhat.com/show_bug.cgi?id=1694329

This issue is still reproducible with today Firefox nightly build (70.0a1 2019-08-09) on Gnome Shell 3.32.2 Wayland session on Ubuntu 19.04.

Duplicate of this bug: 1530070

I can report the same issue on X11 (I can't use Wayland because I use Nvidia-PRIME).

Enabling a regular system title bar allows me to drag with touch, but I want it disabled. I use the MOZ_XINPUT2 environment variable which fixes dragging within the webpage.

Experiencing the same issue on KDE Plasma, Fedora 33, as well as GNOME Shell 3.38.1 on PoP OS. On Fedora, this issue is present under both Wayland and X11.

Tested with firefox_wayland, firefox_x11 packages, firefox installed from snapd on Fedora.

On PoP OS, I am running Firefox 82.0.3.

When the window is maximized, if I start dragging above the top of the window, dragging works as expected. Starting the gesture on the titlebar, however, does not move the window.

(In reply to personalizedrefrigerator from comment #11)

When the window is maximized, if I start dragging above the top of the window, dragging works as expected. Starting the gesture on the titlebar, however, does not move the window.

I see the same behavior. Arch Linux, Gnome 3.38.2, Wayland, Firefox 84.0 running with Wayland support not X11 mode

Oh and this is on a Surface Go

Assignee: nobody → jhorak

Same behavior for me on an XPS 13 2-in-1. How is this issue related to https://bugzilla.mozilla.org/show_bug.cgi?id=1283299 ?

Add support for dragging window on touch event.

Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/61c28c4c667c
Start drag operation on touch event on draggable area; r=stransky
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/568884c45cf9
Start drag operation on touch event on draggable area; r=stransky
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

gdk takes touch-move and touch-end events when dragging the window.
As a result, the touch-start event was propagated, but not touch-end, making firefox think
that all subsequent touches were in addition to the original, breaking mosst touch screen input
(on Linux with MOZ_USE_XINPUT2).

Comment on attachment 9247419 [details]
Bug 1418792 - Send TouchCancel event just before dragging window

Revision D129349 was moved to bug 1722899. Setting attachment 9247419 [details] to obsolete.

Attachment #9247419 - Attachment is obsolete: true
Attachment #9247419 - Attachment description: WIP: Bug 1418792 - Remove propagation of touch events just before dragging window. → WIP: Bug 1418792 - Send TouchCancel event just before dragging window
Attachment #9247419 - Attachment is obsolete: false
Attachment #9247419 - Attachment description: WIP: Bug 1418792 - Send TouchCancel event just before dragging window → Bug 1418792 - Send TouchCancel event just before dragging window

Comment on attachment 9247419 [details]
Bug 1418792 - Send TouchCancel event just before dragging window

Revision D129349 was moved to bug 1722899. Setting attachment 9247419 [details] to obsolete.

Attachment #9247419 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.