Closed Bug 1418819 Opened 5 years ago Closed 5 years ago

Link tool in Composer not working

Categories

(SeaMonkey :: Composer, defect)

SeaMonkey 2.49 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1417819

People

(Reporter: irekyu, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_1) AppleWebKit/604.3.5 (KHTML, like Gecko) Version/11.0.1 Safari/604.3.5

Steps to reproduce:

1)Open a composer instance
2)Type some text
3)Select the text and display the link UI
4)Use the 'Choose a File' button  (bottom right of the sheet)
5)Select a file in the UI that appears and click open

Note: 
I am using macOS High Sierra 10.12.1 (17B48)
The specific SeaMonkey version is 2.49.1. Build identifier: 20171016003553


Actual results:

The file path is not displayed in the Link Sheet and the OK button remains disabled


Expected results:

The file should have been displayed and the OK button should enable
Could you open Tools->Web Development->Error Console and see if a "GetOS() is undefined error" is shown when you open the Link UI dialog.
This is what I see when I turn on the debug tools

Timestamp: 11/27/17, 11:13:27 PM
Error: ReferenceError: GetOS is not defined
Source File: chrome://editor/content/editorUtilities.js
Line: 545
Then it is the same error as Bug 1417819. It will be fixed in 2.49.2. Please reopen if the next version doesn't fix it.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1417819
You need to log in before you can comment on or make changes to this bug.