Title bar switch does not work in Ubuntu 17.10

RESOLVED DUPLICATE of bug 1419460

Status

()

defect
RESOLVED DUPLICATE of bug 1419460
a year ago
a year ago

People

(Reporter: rnd, Unassigned)

Tracking

({nightly-community})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20171108130936

Steps to reproduce:

In nightly build (59.0a1 (2017-11-19) (64-bit)), de-selecting the 'title bar' switch in the lower left corner of 'customize' does not hide or remove the title bar. 
Running the nightly build in Ubuntu 17.10, gnome-shell.


Actual results:

no change in title bar.


Expected results:

title bar should be removed/hidden.
Component: Untriaged → Toolbars and Customization
OS: Unspecified → Linux
Summary: nightly-community; title bar switch does not work in Ubuntu 17.10 → Title bar switch does not work in Ubuntu 17.10
(Reporter)

Comment 1

a year ago
Found a fix;
in about:config, set widget.allow-client-side-decoration to true (default is false).
Then unset 'title bar' switch in lower left corner of 'customize' window.

FIXED.

Comment 2

a year ago
Maybe a dupe of bug 1419460? Hard to tell.
Blocks: gtktitlebar
Component: Toolbars and Customization → Widget: Gtk
Product: Firefox → Core
See Also: → 1419460
Comment 0 sounds exactly like bug 1419460. I can't make much sense of comment 1; widget.allow-client-side-decoration also doesn't exist anymore. But if this is indeed somehow fixed as comment 1 claims (which I can't confirm on Ubuntu), then there's no point in keeping this open either.
No longer blocks: gtktitlebar
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
See Also: 1419460
Duplicate of bug: 1419460
(Reporter)

Comment 4

a year ago
I'm running nightly build "59.0a1 (2017-11-24) (64-bit)", on Ubuntu 17.10, gnome-shell v 3.26.1, Wayland display server.
In about.config, the following is definitely available and visible in my version.

widget.allow-client-side-decoration;true
The pref is probably still present in your profile because you flipped it before it got removed in bug 1418829. If you reset it, it should go away.
You need to log in before you can comment on or make changes to this bug.