local directory for IMAP server settings creates problems with roving profile

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
17 years ago
10 years ago

People

(Reporter: mark, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

When using IMAP the mail resides on the server. When synchronising mail to allow
offline use the mail cache is stored in the folder "X:\Documents and
Settings\user.domain\Application
Data\Mozilla\Profiles\user\o9imp06f.slt\ImapMail" but this folder is part of the
roaming profile under Windows 2000 or XP. This creates slow logon and logoff for
windows if the IMAP folder is large. A better place to cache the IMAP folder is
"X:\Documents and Settings\user.domain\Local Settings\Application
Data\Mozilla\Profiles\user\o9imp06f.slt\ImapMail". See related bug 74085 for
more info on this problem.

When updating the Local Directory with the correct path I noticed that the
existing folders did not move. This created duplicate files which I had to clear
up by hand. Messy.

Reproducible: Always
Steps to Reproduce:
1. Check Mail and Newsgroup Account Settings, Server Settings for an IMAP account
2. Look at the Local directory


Actual Results:  X:\Documents and Settings\user.domain\Application
Data\Mozilla\Profiles\user\o9imp06f.slt\ImapMail

Expected Results:  X:\Documents and Settings\user.domain\Local
Settings\Application Data\Mozilla\Profiles\user\o9imp06f.slt\ImapMail

This bug could perhaps be fixed as part of related bug 74085.

Updated

16 years ago
QA Contact: huang → gchan

Comment 1

16 years ago
I recommend wontfix for this bug, assuming that "Local Settings" is stored on
the local computer, i.e., not the networked resource. We must give network
administrators the ability to store profile data on networked resources for
greater ease of centralized management, to wit, backup.
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 3

13 years ago
(In reply to comment #1)
> I recommend wontfix for this bug, assuming that "Local Settings" is stored on
> the local computer, i.e., not the networked resource. We must give network
> administrators the ability to store profile data on networked resources for
> greater ease of centralized management, to wit, backup.

As a network administrator, I'd like to say - please don't ignore this issue;
it's been brought up many times.  Pop folders should (maybe) be backed up, IMAP
should not.  That's what we have an IMAP server for - to keep the mail in a
central, manageable location and OFF the workstation.  This way we can have real
usable webmail and efficent roaming access.  There's no need to keep it in a
centralised location for us because that's already done.  Even with pop we might
like to keep it in a different location outside the salt.  Yes, somewhere out in
the world there may be a network where people download IMAP messages and delete
them off the server, but I have never seen such a thing in 10 years of consulting.

The original submitter is wrong though, in that we don't need a tool to
automatically move the folder contents when manually changing the location of
the folder.  We shouldn't have to manually change the location each time we
create an account.  Storing IMAP information in LocalSettings should be the
default behavior, or selectable in the preferences and settable as a defaultpref
or lockpref in autoconfig.

Comment 4

11 years ago
still an issue for you?
perhaps should be dependent on bug 377242
Assignee: mscott → bienvenu
QA Contact: grylchan → networking.imap

Comment 5

10 years ago
incomplete per comment 4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.