Creating an account on https://developer.mozilla.org does not work when linking my Github account.

RESOLVED WORKSFORME

Status

Mozilla Developer Network
Account Help
RESOLVED WORKSFORME
2 months ago
2 months ago

People

(Reporter: John Apted, Assigned: jwhitlock)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

2 months ago
Created attachment 8929968 [details]
Screenshot from 2017-11-20 03-33-14.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171115094513

Steps to reproduce:

Went to https://developer.mozilla.org/en-US/users/account/signup after linking my Github account. After accepting the terms of service I clicked on the "Create my MDN account" button.


Actual results:

It took me to a "Permission Denied" page preventing the account from being created. 


Expected results:

Account should have been created.
(Assignee)

Comment 1

2 months ago
I'm sorry you're having trouble creating an MDN Web Docs account.

I wonder if your starting page makes a difference. Can you try this:

1. Start on the homepage: https://developer.mozilla.org/en-US/
2. Click on the "Sign In" link at the top right
3. Go through account signup again.
Assignee: nobody → jwhitlock
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(johnapted)
(Reporter)

Comment 2

2 months ago
(In reply to John Whitlock [:jwhitlock] from comment #1)
> I'm sorry you're having trouble creating an MDN Web Docs account.
> 
> I wonder if your starting page makes a difference. Can you try this:
> 
> 1. Start on the homepage: https://developer.mozilla.org/en-US/
> 2. Click on the "Sign In" link at the top right
> 3. Go through account signup again.

Hi John,

Yeah I am unsure what the issue is. I've set my browser to have a low Internet footprint so many functions are deactivated in the browser. Not too sure which deactivated feature has caused this bug but it would be nice to get to the bottom of it.

I just tried going via your steps and got to the same error page.

Is there anything specifically that need to be enabled to allow for the account to be created?
Flags: needinfo?(johnapted)
(Assignee)

Comment 3

2 months ago
I have not studied the GitHub OAuth2 workflow enough to know what browser features are needed to make it work. I believe you'll need cookies, local storage, and JavaScript enabled.
(Reporter)

Comment 4

2 months ago
Hi John,
I made sure those 3 settings were enabled but still got the error message, so there must be another setting that needs to be enabled for the account to be created.
(Assignee)

Comment 5

2 months ago
I'm sorry that didn't work. I suggest you try enabling other features until it works, or use default browser settings and selectively disable features until it stops working.
(Assignee)

Comment 6

2 months ago
Account creation appears to be working with standard browser configurations. If you find what setting is blocking account creation, please let us know.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.