Closed Bug 1418897 Opened 5 years ago Closed 5 years ago

Mac Firefox requires typing Backspace twice to delete a chracter when typing Hangul

Categories

(Core :: Widget, defect)

57 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1403759

People

(Reporter: dapsdh, Unassigned)

Details

(Keywords: inputmethod)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171112125346

Steps to reproduce:

1. Access to http://www.danilatos.com/event-test/ExperimentTest.html
2. Type Hangul "ㄱ" in the Editing area.
3. Press Backspace key.
4. Press Backspace key again.


Actual results:

The first backspace key does not delete the letter "ㄱ". Only the composition state is ended. To delete the letter, you must the enter the backspace key again.


Expected results:

If the backspace key is entered during Hangul composition, the character immediately entered must be deleted. 
In addition, if the backspace key is pressed while the consonant and vowel have already been combined, the letter should return to its previous letter and the composition must be maintained. 
ex. "가" -> backspace -> "ㄱ" -> ㅏ -> "가"
Component: Untriaged → Widget
Keywords: inputmethod
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1403759
You need to log in before you can comment on or make changes to this bug.