Closed Bug 1419052 Opened 3 years ago Closed 3 years ago

Crash in d2d1.dll@0x8937f

Categories

(Core :: Graphics, defect, P3)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1429608
Tracking Status
firefox57 --- affected
firefox58 --- affected
firefox59 --- affected

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [gfx-noted])

Crash Data

This bug was filed from the Socorro interface and is
report bp-25747b7a-5022-4a07-a7bf-771d50171120.
=============================================================

Seen while looking at nightly crash stats and in calxite's report: http://bit.ly/2iAgm2y. This is one signature, there are other variants. Currently higher volume in nightly and beta than in 57 release.

Comments: I think the crash happens because of the latest insider Windows 10 build which is 17035, tested the latest stable Windows 10 build and nothing crashed, upgraded to latest insider and it's crashing at random times.

59.65% in signature vs 01.42% overall) platform_version = 10.0.17035

Top 10 frames of crashing thread:

0 d2d1.dll d2d1.dll@0x8937f 
1 d2d1.dll d2d1.dll@0x89ae2 
2 d2d1.dll d2d1.dll@0x89c27 
3 d2d1.dll d2d1.dll@0x5f98b 
4 d2d1.dll d2d1.dll@0x5fa51 
5 d2d1.dll d2d1.dll@0x601d8 
6 d2d1.dll d2d1.dll@0x60435 
7 d2d1.dll d2d1.dll@0x600b4 
8 d2d1.dll d2d1.dll@0x63068 
9 d2d1.dll d2d1.dll@0x62e34 

=============================================================
Depends on: 1421290
Whiteboard: [gfx-noted]
I reprocessed the crash from comment 0 after fixing bug 1419052 and the new signature is:
[@ CSysToHwTransferBuffer::NotifyWrittenBytes ]

I'll kick off reprocessing for other signatures with d2d1.dll in them.
Crash Signature: [@ d2d1.dll@0x8937f] → [@ d2d1.dll@0x8937f] [@ CSysToHwTransferBuffer::NotifyWrittenBytes ]
Duping to philipp's newer bug, Bug 1429608.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1429608
You need to log in before you can comment on or make changes to this bug.