Closed Bug 1419117 Opened 2 years ago Closed 2 years ago

[cs] Update icons of Firefox desktop search modules

Categories

(Firefox :: Search, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 59
Tracking Status
firefox57 --- wontfix
firefox58 --- fixed
firefox59 --- verified

People

(Reporter: MikkCZ, Assigned: MikkCZ)

References

()

Details

Attachments

(1 file)

Seznam.cz
- https://www.seznam.cz/media/img/seznam-icons/favicon.ico
- 32px https://www.seznam.cz/media/img/seznam-icons/favicon-32x32.png
- 16px https://www.seznam.cz/media/img/seznam-icons/favicon-16x16.png

Mapy.cz
- https://mapy.cz/img/favicon/favicon.ico

Other
- seems other icons are up to date, but I should check if they match the en-US original, or different source is used

(Francesco Lodolo [:flod] from bug 1403111)
> Icon for Firefox desktop are .ico, embedding both 16px and 32px

Documentation, how to modify search plugins: https://mozilla-l10n.github.io/documentation/products/searchplugins/setup_searchplugins.html
Comment on attachment 8930392 [details]
Bug 1419117 - [cs] Update icons of Firefox desktop search modules and use https,

https://reviewboard.mozilla.org/r/201546/#review207274

Great job Michal, everything looks good.
Attachment #8930392 - Flags: review?(francesco.lodolo) → review+
Pushed by francesco.lodolo@mozillaitalia.org:
https://hg.mozilla.org/integration/autoland/rev/931eb8bca980
[cs] Update icons of Firefox desktop search modules and use https, r=flod
https://hg.mozilla.org/mozilla-central/rev/931eb8bca980
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Francesco is this change something we can uplift to beta 58, so it's in the January release? Of course after I can verify in nightly.

CCing Martin Stružský to let him know we have updated the icons.
Flags: needinfo?(francesco.lodolo)
(In reply to Michal Stanke (Mozilla.cz) [:MikkCZ][:mstanke] (use needinfo) from comment #5)
> Francesco is this change something we can uplift to beta 58, so it's in the
> January release? Of course after I can verify in nightly.

Yes. Once the bug is fixed and verified, I can take care of the uplift request.
Flags: needinfo?(francesco.lodolo)
I have verified in 20171122103138 (Linux) with a clean profile, that the new icons are displayed and all touched search modules work correctly.

Francesco, you can uplift, when you have time.
Status: RESOLVED → VERIFIED
Looks like I need to move this over to Firefox::Search to be able to request uplift.
Component: cs / Czech → Search
Product: Mozilla Localizations → Firefox
Target Milestone: mozilla58 → ---
Version: unspecified → Trunk
Comment on attachment 8930392 [details]
Bug 1419117 - [cs] Update icons of Firefox desktop search modules and use https,

Approval Request Comment

[Feature/Bug causing the regression]: -

[User impact if declined]: smaller icons, not https search on one searchplugin

[Is this code covered by automated tests?]: no

[Has the fix been verified in Nightly?]: yes

[Needs manual test from QE? If yes, steps to reproduce]: no

[List of other uplifts needed for the feature/fix]: -

[Is the change risky?]: no

[Why is the change risky/not risky?]: only affect one language (cs), tested, minor changes

[String changes made/needed]: -
Attachment #8930392 - Flags: approval-mozilla-beta?
Comment on attachment 8930392 [details]
Bug 1419117 - [cs] Update icons of Firefox desktop search modules and use https,

This patch updates icons of Firefox desktop search modules and was verified. Beta58+.
Attachment #8930392 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Target Milestone: --- → Firefox 59
You need to log in before you can comment on or make changes to this bug.