Closed Bug 1419133 Opened 3 years ago Closed 3 years ago

Blank Archive and Delete buttons when multiple messages are selected.

Categories

(Thunderbird :: Mail Window Front End, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(thunderbird58 fixed, thunderbird59 fixed)

RESOLVED FIXED
Thunderbird 59.0
Tracking Status
thunderbird58 --- fixed
thunderbird59 --- fixed

People

(Reporter: walts48, Assigned: Paenglab)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171120100042

Steps to reproduce:

Created test profiles and an email account
Downloaded emails for that account
Selected multiple emails in an account to archive or delete



Actual results:

The buttons don't have any icons or text visible
Icons and text are barely visible when a button is hovered over with a mouse

No icons problem first appeared in Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Thunderbird/58.0a1 BuildID: 20171008030210 Icons not visible, text in buttons
Built from https://hg.mozilla.org/comm-central/rev/48a4c3f584cc13bef1fc1c405c7edb312dc7995e

No text and icon problem first appeared in Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Thunderbird/58.0a1 BuildID: 20171024030201
Built from https://hg.mozilla.org/comm-central/rev/ad44eb6ab134472e1399e1f4cd6de6e0f94dd478 


Expected results:

Buttons should have visible icons and text.
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Attached patch Bug1419133.patchSplinter Review
I somehow missed Linux. Mac and Windows have this color defined.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8930191 - Flags: review?(acelists)
Comment on attachment 8930191 [details] [diff] [review]
Bug1419133.patch

Review of attachment 8930191 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, works for me.
Attachment #8930191 - Flags: review?(acelists) → review+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/7d2c6071fa82
fix text contrast on buttons in multimessageview's header. r=aceman
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
(I made the commit message sound a little nicer)
Target Milestone: --- → Thunderbird 59.0
Comment on attachment 8930191 [details] [diff] [review]
Bug1419133.patch

Reading comment #0, this needs uplift.
Attachment #8930191 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.