Closed Bug 1419270 Opened 2 years ago Closed 2 years ago

Make it possible to annotate attr getters and setters separately as needing subject principals

Categories

(Core :: DOM: Core & HTML, defect)

53 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox58 --- fixed
firefox59 --- fixed

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

Details

(Whiteboard: Beta approval requested for part 1 only)

Attachments

(2 files, 1 obsolete file)

We're using NeedsSubjectPrincipal a lot more (e.g. see the GenerateCSS2PropertiesWebIDL.py changes in bug 1415352).  Some of the uses are fairly perf-sensitive; we should avoid doing the work if we don't need to.  In the inline style case, none of the getters need it, for example.
Flags: needinfo?(bzbarsky)
Flags: needinfo?(bzbarsky)
Summary: Make it possible to annotate attr getters and setters separately as needing caller principals → Make it possible to annotate attr getters and setters separately as needing subject principals
Flags: needinfo?(bzbarsky)
Attachment #8934589 - Flags: review?(kyle) → review+
Attachment #8934590 - Flags: review?(kyle) → review+
Flags: needinfo?(bzbarsky)
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/03636aaf6cd7
part 1.  Add NeedsSubjectPrincipal to the extended attributes we compute for interface members.  r=qdot
https://hg.mozilla.org/integration/mozilla-inbound/rev/69b3a04f5947
part 2.  Use getter or setter specific NeedsSubjectPrincipal annotations more.  r=qdot
https://hg.mozilla.org/mozilla-central/rev/03636aaf6cd7
https://hg.mozilla.org/mozilla-central/rev/69b3a04f5947
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Comment on attachment 8934589 [details] [diff] [review]
part 1.  Add NeedsSubjectPrincipal to the extended attributes we compute for interface members

Requesting beta approval for this part, because the patches for bug 1424474 depend on it.

Approval Request Comment
[Feature/Bug causing the regression]:  See bug 1424474.
[User impact if declined]:  See bug 1424474.
[Is this code covered by automated tests?]:  Yes.
[Has the fix been verified in Nightly?]:  Yes.
[Needs manual test from QE? If yes, steps to reproduce]: No.
[List of other uplifts needed for the feature/fix]: None.
[Is the change risky?]: No.
[Why is the change risky/not risky?]:
[String changes made/needed]:
Attachment #8934589 - Flags: approval-mozilla-beta?
Note: I am only requesting approval for part 1.  Part 2 doesn't need backporting.
Whiteboard: Beta approval requested for part 1 only
Attachment #8940305 - Attachment description: Beta 58 backport of part 3 without backported → Beta 58 backport of part 3 for bug 1424474 without this change backported
Attachment #8940305 - Attachment is obsolete: true
Comment on attachment 8934589 [details] [diff] [review]
part 1.  Add NeedsSubjectPrincipal to the extended attributes we compute for interface members

Take this because the patches for bug 1424474 depend on this one. Beta58+.
Attachment #8934589 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
bz we had some conflicts with the second patch when we tried to uplift to beta. Could you please take a look?
Flags: needinfo?(bzbarsky)
> bz we had some conflicts with the second patch when we tried to uplift to beta. Could you please take a look?

Per comment 6, part 2 did not need uplifting.
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.