Site navigation bar caches results

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: tg, Assigned: sballard)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.0+) Gecko/20020502
BuildID:    2002050208

Mozilla correctly displays the Site Navigation Bar (I have it set to "as
needed") when I do a bugzilla search, but if I click on the back button and then
search for something that has "Zarro Boogs found", the site navigation bar seems
to cache the result.

What this means is that if I click on any of the buttons (eg "Last") the result
displayed is, for example, the last on the previous list.

Reproducible: Always
Steps to Reproduce:
1. Go to bugzilla
2. Enter a search string that will yield results (like "XML").
3. Once the page is displayed, click the back button.
4. Enter a search string that will not yield result (I have found that "Zarro
Boogs" works :).
5. Click on the "Last" button on the Site Navigation Bar.
6. You should be taken to the last bug on the previous list.

Actual Results:  I was taken to the last bug on the previous last

Expected Results:  I would have expected Mozilla to "grey" out the options on
the bar.
Stuart, can you take a look sometime?
Assignee: sgehani → sballard

Comment 2

17 years ago
trying with other sites, I don't see any sign of the bar "caching" results.

I would guess the problem was simply that bugzilla was generating the first /
last / next / previous links in a quirky way - the caching is/was in the
bugzilla code (it uses cookies), not in the link bar.  suggest resolving this as
WORKSFORME, if not, then it's a bugzilla bug rather than a mozilla bug.

reporter (Trevor): do (or did) you see this on any other sites?
(Reporter)

Comment 3

17 years ago
No, but I didn't try other sites either.

Your explaination sounds feasible Michael, I'll try it out on other sites at 
home tonight and see if I can reproduce the same results as you.

Comment 4

17 years ago
Trevor: are you still out there?  can you reproduce this with a recent build of
mozilla (e.g. 1.1beta)? if you can, please comment with details. if not, please
resolve this as WORKSFORME. thanks.
(Reporter)

Comment 5

17 years ago
Sorry, I have been flat out like a lizard drinking.

Stupid question, but I can't find how to turn on the site navigation bar. Any
hints? I don't know if it matters or not, but my build is 20020606 (1.0).

Thanks.

Comment 6

17 years ago
no problem.

you can't get the site navigation bar in 1.0 - it was removed from the 1.0 build
because of performance problems.  for bug reports to be useful, they have to be
identified against recent builds anyway - try downloading 1.1beta (or a recent
nightly trunk build).  in my experience, 1.1beta is as stable as 1.0, but do
read the release notes.

Comment 7

16 years ago
WFM with 2002090704/trunk/win2k.

reporter (Trevor): can you reproduce this bug with a recent build of mozilla
(for example, 1.1)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.
(Reporter)

Comment 8

16 years ago
I have (finally!) got around to verifying this... and yes it "WORKSFORME".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 9

16 years ago
great. thanks.

verified.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.