Closed Bug 1419538 Opened 2 years ago Closed 2 years ago

Log entries do no longer contain object details

Categories

(Testing :: Marionette, defect)

Version 3
defect
Not set

Tracking

(firefox-esr52 unaffected, firefox57 unaffected, firefox58 fixed, firefox59 fixed)

RESOLVED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed
firefox59 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

Details

(Keywords: regression)

Attachments

(1 file)

I just noticed that we no longer print the capabilities in the log entry for start_session. Instead it's only an empty dict:

1511295064335	Marionette	TRACE	81 <- [1,1,null,{"sessionId":"f448ba13-521f-7a4e-bebf-6fff6113f164","capabilities":{}}]

But when I print the session capabilities afterward, everything has been transferred correctly: 

{u'rotatable': False, u'browserVersion': u'59.0a1', u'acceptInsecureCerts': False, u'moz:headless': True, u'moz:webdriverClick': False, u'moz:accessibilityChecks': False, u'timeouts': {u'pageLoad': 300000, u'implicit': 0, u'script': 30000}, u'browserName': u'firefox', u'moz:profile': u'/var/folders/4k/sf4gz5fn3kl9hr3nd7pzbvhc0000gn/T/tmp2ebRwV.mozrunner', u'platformVersion': u'16.7.0', u'moz:processID': 10144, u'pageLoadStrategy': u'normal', u'platformName': u'darwin'}

As it looks like this is only an issue with logging, but this would affect our ability to investigate issues for geckodriver by just inspecting the trace logs.

We should get this fixed.
This actually regressed in Firefox 58. I will have a look at the regression range.
It's a regression from bug 1403577 and specifically to the following commit:
https://hg.mozilla.org/mozilla-central/rev/f5c5cc198dda

After some checks I noticed that this line got lost:

> let s = JSON.stringify(msg.toPacket());

As such we have an arbitrary Javascript object, which indeed will only be added as `{}`.
Assignee: nobody → hskupin
Blocks: 1403577
Status: NEW → ASSIGNED
Summary: Returned capabilities are no longer visible in the log entry for start_session() → Log entries do no longer contain object details
Comment on attachment 8933298 [details]
Bug 1419538 - Marionette log entries should show object details.

https://reviewboard.mozilla.org/r/204234/#review209816

This will stop truncating the packets for printing.  Instead you
need to fix Message#toString to also call JSON.stringify.
Attachment #8933298 - Flags: review?(ato) → review-
Comment on attachment 8933298 [details]
Bug 1419538 - Marionette log entries should show object details.

https://reviewboard.mozilla.org/r/204234/#review209816

Oh, that is true. Updated patch upcoming.
Comment on attachment 8933298 [details]
Bug 1419538 - Marionette log entries should show object details.

https://reviewboard.mozilla.org/r/204234/#review209886
Attachment #8933298 - Flags: review?(ato) → review+
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7240ede80d50
Marionette log entries should show object details. r=ato
https://hg.mozilla.org/mozilla-central/rev/7240ede80d50
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
This test harness regression also affects beta. Please uplift it. Thanks.
Whiteboard: [checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.