handle the case where the initial about:blank is controlled, but the final document load is not covered by any service worker scope

RESOLVED DUPLICATE of bug 1293277

Status

()

defect
RESOLVED DUPLICATE of bug 1293277
2 years ago
Last year

People

(Reporter: bkelly, Assigned: bkelly)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Please see the explanation in the spec issue here:

https://github.com/w3c/ServiceWorker/issues/1232

We don't currently do initial about:blank service worker inheritance, but we are going to start in bug 1293277.

My current proposal is to simply force a new inner window to be created in this case, similar to what happens if a cross-origin load or document.open() occurs.
I'm just going to do this in bug 1293277.
No longer blocks: ServiceWorkers-compat
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
No longer depends on: 1293277
Resolution: --- → DUPLICATE
Duplicate of bug: 1293277
You need to log in before you can comment on or make changes to this bug.