Closed Bug 1419749 Opened 3 years ago Closed 3 years ago

static assertion in jit/MacroAssembler.cpp on sparc

Categories

(Core :: JavaScript Engine: JIT, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1420115

People

(Reporter: petr.sumbera, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171112125346

Steps to reproduce:

This is probably caused by fix for Bug 1417555 which introduced the assertion.

26:04.31 In file included from /scratch/firefox/obj-sparc64-sun-solaris2.11/js/src/Unified_cpp_js_src17.cpp:2:0:
26:04.31 /scratch/firefox/js/src/jit/MacroAssembler.cpp: In member function 'void js::jit::MacroAssembler::wasmCallImport(const js::wasm::CallSiteDesc&, const js::wasm::CalleeDesc&)':
26:04.31 /scratch/firefox/js/src/jit/MacroAssembler.cpp:2940:5: error: static assertion failed: by constraint
26:04.31      static_assert(ABINonArgReg0 != WasmTlsReg, "by constraint");
26:04.31      ^
Component: Untriaged → JavaScript Engine: JIT
Product: Firefox → Core
Hah right, on the none platform all these static assertions I'm adding will certainly fail, since all the registers are the same (invalid/none)... Sorry about this, I will make a patch soon; I think a proper fix is to wrap this static_assert within an #ifndef JS_CODEGEN_NONE, or even better, to pave the way with a new macro jit_static_assert that hides this ifndef.
Flags: needinfo?(bbouvier)
Patch attached to bug 1420115.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1420115
Flags: needinfo?(bbouvier)
You need to log in before you can comment on or make changes to this bug.